Download

Equip Montage keeps being interrupted.

So I’ve tried doing this two different ways. The first one is the one pictured below. I call an anim montage within the controller to play an equip montage. I do not want this montage to be interrupted, so I created a function called “Has Priority” in order to help ensure that the anim finishes. This means that when you press the equip button, you can not jump or sprint until the montage is finished. However, you can sprint or jump THEN press the equip button, and you’ll go through the montage. Not really ideal, but it works. The issue is when I press the equip button on my jump sequence. It works fine until I land, causing the montage to be interrupted.

The second option I used was calling a play anim slot function from the anim bp. This worked fine, however, I had issues using the DoOnce node. I thought I had figured it out, but when testing it I noticed that it too can be interrupted.

Basically, no matter how I rig the logic up, my equip montage is somehow interrupt able and I don’t want to be. Thanks for the help.

Seems way overcomplicated to me…this is how I do it

Good old John Galt coming to the rescue yet again (helped me with some aimoffsets over the summer). This worked perfectly. I definitely need to subscribe to you, so I can keep up with some of your work.

So this didn’t fix it. Upon further testing, I noticed something strange. When I press the equip button THEN jump, works fine. If I jump THEN press the equip button, the landing interrupts the equip montage and stops it from playing. The code after the montage play function is still processed, however. I have the landing anim playing in a different slot than the equipping montages, so what could cause it?

I talked about this in my stream today https://youtu.be/AhPsKVPs4KU?t=6405 see if that helps

Thanks John for adding my question to your stream. I truly appreciate it buddy. I went ahead and started from scratch last night, so it will take my awhile to actually apply what you did to see if it works. But looking at your stream, I think the issue was with my landing compression slot. I never had it on a blend (but I did have my weapon slot on a blend), so that is what probably did it. As the weapon slot was blending in, the landing compression slot overrode the weapon slot because there was no blend for the landing compression slot. Feel kinda stupid now after thinking about it haha. But thanks man, and I’ll just rework my jumping logic this time and apply your methods. You’ve helped me a bunch today. Truly appreciated.

I must clearly be missing something here. Who is John and could you describe the solution that worked for you? Running into the same problem.

I Am John Galt,

This was a conversation from a while ago, where I helped him with an issue he was having during one of my weekly live streams. That video has since been deleted, however, there is tons of informative videos on my youtube page.

https://www.youtube.com/channel/UCpu…yusqni1ZnWdBQ?

Regards,
IAmJohnGalt