EQS path length scoring doesn't work properly with inversed linear setting

Here is my setup - I run a query with a single test enabled at the moment - to be as close to the current position as possible but at least 200 away (needed for a combined test later). But regardless if I use linear or inversed linear scoring it gives higher score to points further away instead of the closest ones.
G1_EnvQContext is my player character (I generate grid around him).
I have this issue in both 4.10 (the most stable for me until 4.12) and 4.12 (Preview 1) (the newest one)

Actually I’ve noticed that distance is calculated as a path instead of a vector, so I’ve used the distance query instead. Feels like a band-aid solution, but at least it works.


You’ve stated that you found a solution to your issue. Is this issue now resolved, or are you still experiencing problems with your setup?

Hello, thank you for your response!
It’s not a solution, more like a workaround. In fact, there is a double issue now:

1)Distance check with EQS returns path length instead of vector distance (which is acceptable for me but in case I need a vector length it would cause problems). In other words, two different functions (Distance and Path) call the same code.

2)Inversed linear scaling still doesn’t work for path check (but works for “distance”(that is path as well) checks).

One suggestion regarding your setup. On your PathLength test, click the dropdown arrow underneath the Score tab and select the maximum score option instead of average score. This way, you’ll be able to get the items with the maximum score (which are the items that are closest to 0 since you’re using inverse linear scoring).

Does that make any difference?

Just made a quick test with this setting - nope, still the same. I think it’s just that the equation for inversed linear scoring could be set the same as for linear.

As for distance scoring path instead of vector length it is probably more complicated, but can as well be the same type of problem.

Updated to 4.12 Preview 2 - problem still exists in both 4.10 and 4.12 P2

After some further investigation, I have been unable to reproduce this issue on my end, which leads me to believe I am missing a small setting. Could you please provide a test project? You can zip up the project, upload it to dropbox, and PM me a download link through the forums: https://forums.unrealengine.com/member.php?160394-Sean-Flint

This is very strange because I’m having the same behavior in the most basic project I could make. I’m currently uploading the zip archive to dropbox and will share a link asap.

Update: looks like an editor issue - I’m getting strange behavior for my EQS and physics asset as well (thought it was different, but now I’m pretty sure it’s the same). Every time I close my project and reload it it resets its value to default (linear). The same for physics asset parameters resetting on blueprint reopen.


I have been able to reproduce your issue and have entered a bug report, UE-30470. Thank you for your report.

Have a great day