EPICS plans to support - sub 100$ tablets

I picked up a sub 100$ tablet ( as well as I have a sub 50$ tablet being shipped (7 Inch Android 6.0 Children's Tablets 4000mAh Capacitive Screen OLED Front Camera Pad For Kids - Free shipping - DealExtreme)

Sadly though - My 100~ tablet wont run unreal 4 (tappy chicken from epics store), it will run unreal 3 (the epic citadel) as well as every unity game I’ve tried.

All unreal 4 games (from store or deployed by me from editor) just sit at a black screen for a moment then quit to the dashboard

I know I could just buy a supported 200$ tablet - but that goes against my strategy and might as well switch this project to unity. Is it in epics plans to support these low end devices? I can see this being a huge problem if they don’t as many people will buy these for their kids

Tappy Chicken came from Epics store on the play store and DOES NOT WORK engine shows a black screen - I submitted debug reports and am not able to find logs, the google play icon shows briefly but its a black screen then crash to desktop

How well does Flappy Birds work on these devices.

Typically, sub $100 tablets are such due to being woefully underpowered, even for their own UI, let alone a demanding game engine like UE4.

i think this a big issue that epic chose to ignore and it could well bite them as far as mobile developers go.
the key to mobile games is having it run on a decent proportion of devices, its no good if your game will only run on literally 5 or 6 devices in the world.
yes sub $100 are underpowered but they are common, other engines seem to run on them just fine. out of the 5 (varied and fairly recent) android devices in my house only 1 of them runs ue4, even then its at a low framerate.
ue4 has by far the best set of tools but its performance is just dreadful. if you plan on releasing a mobile game sometime in the next year or 2 the is no other choice but to use another engine.

Did you try running the official versions that is shipped by epic . It may come down to something in your ue4 install being a little messed up.

As far as low end / weird /cheap hardware.

Much of it comes down to vendor/hardware used (were drivers the most recent with that kernel), the ROM used (heavily modified ROM, or AOSP rom). Settings become important for many of these devices (and what the GPU’s support). Its not as “easy” to get them running out of the box with amazing performance but its reasonable. Unfortunately many of the uber cheap chinese tablets (which i have one), in the past, often used really weird chipsets, with half working drivers and features, and heavily modified/broken android roms. The GOOD news, if you get any of the newer ones (4.2+, especially the 4.4) many of them have more respected, tested, feature complete chipsets (Allwinner / mediatek, has largely taken over the cheap sector and has pretty good chip/driver support). Its becoming less, and less frustrating.

I need to re-do this since last time i tried it on these “odd ball” devices was ~4.3 . Does Unreal Engine 4 scale? Well see for yourself - Android Development - Unreal Engine Forums

I have 6 android devices (from 4.1 to 5.1),2 nexus devices, 2 samsung devices, onda tablet, Neptune pine, all of them run UE4. The performance will rarely exceed unity, but if you take into account the hardware’s ability (and using UE4) it actually doesn’t do half bad :). Most importantly they all work (for me).

The newer ~50$ Chinese tablets are surprisingly competent with Allwinner A33 chip.

@ KRushin
are you doing anything special to get ue4 running on those devices?
for me, actually i have 6 devices here
galaxy s - the oldest device i have, does not run ue4, struggles with heavier unity games but runs them (fastest custom rom and kernel i could find)
unbranded chinese phone - runs all unity games without issue, does not run ue4
hannspree tablet - runs all unity games without issue, does not run ue4 (fastest custom rom and kernel i could find)
allwinner tablet - runs all unity games without issue, does not run ue4
galaxy s3 mini - runs all unity games without issue, ue4 runs at ~6fps at best (fastest custom rom and kernel i could find)
nexus 7- runs all unity games without issue, ue4 runs at ~30fps at best

*note none of them run ue4 with mobile hdr enabled, nexus 7 does kind of but at ~1 fps

I updated the title - yes tappy chicken DOES NOT WORK coming directly from EPICS store page

You can see others have this issue in the reviews

"Doesn’t start. Just black screen. Pressed icon to start. Only get black screen. Epic disappointment. "
"When i go on it the skren gows black then it gows on to my home page "

Epic Citadel (unreal 3) from EPICS store runs GREAT on this device, so this makes me think its a bug in unreal 4


Who is the manufacturer and what is the model number? Do you know which GPU it has and the Android version installed?

Hisense Sero7 Tablet

  • 7" (1024 x 600)
  • ARM Cortex A9 1.2GHz Processor 1GB Ram 8GB Flash Storage
  • Rear Camera 2MP 802.11b/g/n
  • KitKat Android 4.4

from the device

model number E2171CA
android version 4.4.2
kernel version 3.0.36++

  • after I was able to fully update the google play store upon crash I was able to send crash reports - I hope those make it to you guys


Looking at the specs, this should have a Mali-400 GPU. Tappy Chicken should work on this device. The best way to try to troubleshoot this would be to have you try packaging a development build of Tappy Chicken with 4.7.4 and capture a logcat from the device to see how far it is getting.

You can run ‘adb logcat -s UE4’ to capture only the UE4 log messages.

– not sure if i did this right, loaded tappy chicken, deployed it using launch tab… started logging, and clicked the icon

EGL_ANDROID_presentation_time is always the last call then nothing - tried a few of my projects

D/UE4 (11372): In the JNI_OnLoad function

D/UE4 (11372): Path found as ‘/storage/emulated/0’

D/UE4 (11372): Font Path found as ‘/system/fonts/’

D/UE4 (11372): In the JNI_OnLoad function 5

D/UE4 (11372): Entering native app glue main function

D/UE4 (11372): Created event thread

D/UE4 (11372): Entered AndroidMain()

D/UE4 (11372): Controller interface supported

D/UE4 (11372): Entering event processing thread engine entry point

D/UE4 (11372): Prepared looper for event thread

D/UE4 (11372): Passed callback initialization

D/UE4 (11372): Found DepthBufferPreference = 0

D/UE4 (11372): Found bPackageDataInsideApk = 0

D/UE4 (11372): Found ProjectName = TappyChicken

D/UE4 (11372): Asking if osOBBInAPK? false

D/UE4 (11372): App is running in Portrait

D/UE4 (11372): Android version is 4.4

D/UE4 (11372): Android manufacturer is Hisense

D/UE4 (11372): Android model is E2171CA

D/UE4 (11372): OS language is set to en_CA

D/UE4 (11372): Passed sensor initialization

D/UE4 (11372): Final commandline: …/…/…/TappyChicken/TappyChicken.uproject /Game/Maps/TappyChickenMap -Messaging -SessionId=DAAB152F4971BF78822892A73A3B691D -SessionOwner=andrew -SessionName=‘Play On Device’ -iterative

D/UE4 (11372): Created sync event

D/UE4 (11372): ==============> GameActive.onCreate complete!

D/UE4 (11372): OnAppCommandCB cmd: 10

D/UE4 (11372): LogAndroidEvents: EnqueueAppEvent : 9, 0

D/UE4 (11372): ==================================> Inside onStart function in GameActivity

D/UE4 (11372): OnAppCommandCB cmd: 11

D/UE4 (11372): LogAndroidEvents: EnqueueAppEvent : 7, 0

D/UE4 (11372): OnAppCommandCB cmd: 0

D/UE4 (11372): OnAppCommandCB cmd: 1

D/UE4 (11372): LogAndroidEvents: EnqueueAppEvent : 0, 1751398600

D/UE4 (11372): LogAndroidEvents: EnqueueAppEvent : 2, 1751398600

D/UE4 (11372): OnAppCommandCB cmd: 6

D/UE4 (11372): LogAndroidEvents: EnqueueAppEvent : 11, 0

D/UE4 (11372): EGL Extensions:

D/UE4 (11372): EGL_KHR_get_all_proc_addresses EGL_ANDROID_presentation_time EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_fence_sync EGL_KHR_create_context EGL_ANDROID_image_native_buffer EGL_KHR_wait_sync EGL_ANDROID_recordable

I was using this logging technique to debug another unrelated issue that I fixed - I noticed the next logging entry after - EGL_KHR_get_all_proc_addresses is FOnlineSubsystemAndroid::Init - maybe this blackscreen issue is related to that?