"EpicGamesLauncher has stopped working" immediately after login

Hi I am installing Unreal engine using EpicGamesLauncherInstaller-2.7.3-2789668.msi. First I had LONG “Please wait” issue which was firewall issue and now resolved and installation moved further. But, happiness did not last longer. Now I have other problems and following are the steps I am doing:

  1. launch launcher EpicGamesLauncherInstaller by double clicking on the icon
  2. I get the login password screen now.
  3. Entered login password correctly
  4. fails with standard windows error “EpicGamesLauncher has stopped working”

I have tried suggestions from Epic Game Launcher crash - Programming & Scripting - Epic Developer Community Forums but, none worked. I have attached logs and dxdiag as well. Please check it and provide solution.
link text

link text
link text
link text

Hello R1.patel,

I’m sorry to hear that you are having trouble with your launcher. I see based on your DXDiag that your GPU drivers are out of date. Could you please visit the NVIDIA website and update to the latest drivers for your card then try again?

Hi thanks for your suggestion.
I installed latest driver from NVIDIA but, now I am getting different error.

Connection to the server failed.
Visit Launcher Troubleshooting.

well network firewall issues were already resolve so, I don’t know why it is giving this error. Also, got it checked with our IT department. Any idea?

Hello again!

If you fixed the connection issue by modifying your Epic launcher shortcut, please check your shortcut and verify that the target line modification “-http=wininet” is still present on your shortcut.

I tried that but that gave the same error. Once it gave “EpicGamesLauncher has stopped working” error.

Hello again!

I apologize for the delayed response. Could you please send me an updated set of logs? Just to verify, the launcher needs port 5222. This port /exception has been allowed?

Hi R1.patel,

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue, please try the suggestion that I mentioned above then post back here with the requested info.