EpicGamesLauncher (0xc000007b)

I know there are several posts about launcher installation errors with this error code already, but I’ve tried the various solutions supplied in those threads to no avail. I’ve tried manually installing directx and then disabling that portion of the installer but I still get the same error when trying to run the launcher. I’ve also tried replacing the d3dcompiler_43.dll in my system folder. I’ve used CCcleaner to tidy up the registry and have made sure windows and my nvidia drivers are up to date but still get the same error.

The log says that installation completed successfully, but the installer window closes very abruptly after the directx installation (or around that point when dx installation is disabled). The installer doesn’t give me any final options and doesn’t create any start menu links, though it does create a desktop shortcut which of course doesn’t work.

Attached is my dxdiag.txt and here is a link to my installer log (because it was too big to attach here):

My system specs are:

Windows 8.1 Pro
Intel(R) Core™ i7-4770K CPU
24576MB RAM
Nvidia GTX780

Sorry for the multiple posts on the same question. The site kept giving me an error so I didn’t think anything had been posted.

If you are seeing this error then the launcher install completed. This means the installer logs won’t be helpful in this case. Usually we need logs from a tool called Dependency Walker to track down the root cause of the problem. You can read more about the process of getting a DW log here(includes some tips on what to look for in your log): Unreal Engine won't launch Error code (0xc000007b) - Getting Started & Setup - Epic Developer Community Forums

If you get stuck, you can post your log and we’ll try to help.

Excellent! Thank you very much. I did not know about Dependency Walker but what a very useful program! I pinpointed the issue as being MSVCR120.DLL and replaced it with the 64bit version and everything is working now. Thanks for your help!

I seem to be having the same issue with the DLL I replaced and and I got the same error

Zaneycox, perhaps you can start a new thread with your dependency walker logs included.