Epic Online Services failed - EOS-ERR-1603

Since I changed my computer I can’t install EOS. The error is EOS-ERR-1603.
I’m using Windows 10 and .NET Framework 3 is already installed as described in:


What I think is causing the error is that I installed Unreal Laucher on D: drive instead C:.


[2021.06.05-01.36.00:679][999]LogEOSInstallService: Installing Epic Online Services
[2021.06.05-01.36.02:245][ 41]LogEOSInstallService: Install of Epic Online Services failed: EOS-ERR-1603
[2021.06.05-01.36.02:245][ 41]LogPortal: Error: FAlertReporter: Reporting Alert code: EOS-ERR-1603

EventError.xml (1008 Bytes)

Thank you!

1 Like

After searching forever why this issue occurs, here’s what I figured out.

There are quite some wanna-be-solutions around the web for this error, like editing the registry, changing file permissions and so on, but they all do nothing for the actual real problem. Forget and don’t bother with those, because if running the launcher as administrator still doesn’t fix the issue, then none of these will.

The solution to this is actually REALLY simple, in case you have installed Epic Games Launcher on a different drive or folder than the default one, as many developers may have. This one will solve the issue:

tldr; Create manually a folder “C:\Program Files (x86)\Epic Games”. Now try to install it, it should work! You may need to run the EpicOnlineServices.msi file manually instead through the launcher.

Yes, all the installer is having an issue with is, that it cannot install this parent folder on it’s own … seriously… nor will it pickup to the correct location of the Epic installation folder to install there. Dev work at it’s best :sweat_smile:


I was also having this same issue, since I installed the Launcher and the engine at another drive (D in my case) and doing the steps (actually one step) above really solved the issue.

Thanks for the hint!

What steps? It’s just ONE step. :laughing:

Glad I could help. This bothered me forever and I really wanted to solve it now. Hopefully, others will find the solution here too quickly.

1 Like

I waited a long time for this to be fixed internally & very surprised this, as of this date, hasn’t been fixed yet. SHAME :rage:

for anyone that has Epic Games Launcher on a ‘different hard drive’
@anonymous_user_679dac17 solution works. (I, personally, found it on Microsoft’s forums.)

ps: if you need to run the msi installation from epic games launcher location then →

  • [MY INSTALL LOCATION]\Epic Games\Launcher\Portal\Extras\EOS\EpicOnlineServics.msi
1 Like

…they don’t check the install location during setup? They offer to change the folder during installation of the client, but don’t think about it when offering installation of some “Service” right within said Client. Yes, it’s only for testing purposes, but still… A Job well done, I would say :-1:

Anyhow, Great Tip, thanks a lot to you m8 !

It worked! Thanks!

Shame to devs, when we users have to find a workaround.
THNX btw

1 Like

So useful! Thanks

Thank you, this helped solving my issue…
(It still persisted in 2021!!)

Still Persisting. It is a shame.

Sorry I got Error EOS ERR 160"2" and cannot find an answer. Changing drive did not help and net framework 3.5 is installed.

Sorry Its still doing it, and nothing works yet

I personally just created a symlink in C:\Program Files(x86)\Epic Games that points to C:\my\custom\install\location\Epic Games and things seem to work so far.

The symlink can be created either by using the mklink command, or a utility such as Link Shell Extension.

1 Like

idk if its normal but when i open the msi, it will start for a few seconds then it would say “1 minute left” then the bar would lower all the way is that normal?

This actually is the only thing that worked flawlessly for me. Thank you