[Epic Official] FBX Import Reporting

Hello,

I looked at the model in 3DsMax and can see that the UVs are all off the map for the cylinder inside the tunnel. Without the UVs properly places, lights will not render properly. I added an updated version of the asset with the map adjusted. It still has overlapping UVs (something that you will have to fix in a modeling program), but it picks up light. Test

Cheers!

Thanks for the response Adam,

I’m not too savy with modelling, though I believe the two feet and the Character 001 are controllers. They were created by the Human CATRig if memory serves, and I don’t think I can remove them without breaking the Rig (correct away if I’m wrong, but I don’t know how I’d animate the legs without those controllers)

Any idea why importing into UDK is successful and why UDK’s export of the same model works fine in UE4? It would be nice to have UE4 make that same conversion to allow for the default 3Ds Max CATRig.

Thanks again

Hi Grogger,

I am looking into issues with the importer. Thank you for reporting this change from UE3 to UE4. I am glad that you have found a work-around, but I have also reported this to our developers so that it can be fixed.

Thank you,

Alexander

Any idea why importing into UDK is successful and why UDK’s export of the same model works fine in UE4? It would be nice to have UE4 make that same conversion to allow for the default 3Ds Max CATRig.

To answer this question. UE3 had a tool to auto-fix the hierarchy for the model. When you exported from UDK, it kept the fixed (one root) hierarchy, allowing it to be imported in UE4.

Hi, Alex told me to post here my problem importing Fbx, im using the same Fbx that i use in UDK (i say this to exclude problems that UE3 has too), so when i change to UE4 i tried to import the same models but crash always that i check “Import Materials”, if i uncheck it then imports well the model and the textures. I realize that the model (because its not mine) has a multi/Sub Object with Standard nodes linked to a texture, i try to delete all to ensure that there arent 2 materials with the same name, but crash anyway,

And i realize something, i see that the model uses 28 material with just 5 textures, because for example, the hair uses 5 material with 2 textures, and upper boddy 6 materials with the same texture, but when i imported in UE4 the engine detects that the mesh uses 28 materials but UE4 (UE3 too but with UDK didnt crash) makes like a joint so if the materials of heads are 21, 22, 23 and 24, if you apply the material just for 21 material the editor applies to all of them. Its hard to explain it but if i make the materials by my own in UE4 and select material 21 and apply to it the hair material , it not necesary to apply it to 22, 23 and 24

I am working with blender 2.7 and the model animation is messing up and i get these warnings FBX bind poses ‘BIND_POSES’ is invalid. it will be ignored. minimum Bones size too large. any one knows what i’m messing up

Here are my files:

I get a similar thing with Modo. I had created a cube and put a coloured material on each side and exported it to .fbx. The fbx imported fine (amazed that even the colours came along since they weren’t textures).

I then added a texture to one face of the cube, editing the fbx itself directly in Modo (because I hadn’t noticed Modo had switch to the fbx file). I then tried importing this file and UE4 crashed as long as import materials was checked.

If it was unchecked then the textures came in without issue, but of course no materials were created by UE4.

After realising what I’d done I modified the materials/textures directly in the modo scene file and exported out to a new .fbx file and imported that (with import materials checked) into UE4 and it was perfectly happy with it and created the materials and imported the textures without issue.

Hello, I am trying to import 3d objects from Zbrush to 3ds max 2011 and into Unreal Engine4. I am able to get my mesh into 3ds max 2011 but I am not sure how to go about updating my FBX exporter from 2011 to 2014. I am given the link from Autodesk: Autodesk | 3D Design, Engineering & Construction Software but they don’t have any 2011 copies.
So, I use the FBX exporter in 3ds max 2011 and it imports into UE4 but without the textures I have assigned to the mesh. I am including my little figure into this message just so you guys can see. I tried importing just the mesh and then applying the texture after but it didn’t match up with the mesh and I am not sure how to re-adjust it.
Well, I can’t seem to show you guys but it sucks:(

Have you imported from Blender before just as a static Mesh? If so start with that first. From what I know about armatures in Blender I’d import the character using FBX remembering to scale the scene by 100. also set the batch mod to scene and check selected objects.

I am assuming and I don’t know because I have not attempted to do this but can you not save your animation as a bvh file and UDK will import that as an armature? If would be two separate imports would it not?

Remember to put your pivot point at the base of the feet with everything centered on the XYZ or the rotation will be all messed up. I was reading yesterday that edge split modifier should be applied and applying modifiers on export should be enabled. You’ll get texture and material errors as well as FBX being too old but the model should import and you can reapply textures from UDK 4.

Yes i have imported meshes fine, even importing a character without any animation works fine it’s jus the animation

I’m having a problem with smooth groups sometimes they work fine other they seem to just randomly decide to throw in hard edges here’s an example:

Normal import options comparisons

  1. is imported as a skeletal mesh with calculate normals
  2. is the same but imported with import normals
  3. shows the mesh in maya
  4. shows the hard/soft edges

I’ve exported the mesh from Maya with smoothing groups, tangents and bi-normals and triangulate checked.

You can find the exported mesh here:

Exported Mesh

Let me know if I’ve missed something as this happens with a lot of the meshes I bring in… but not all of them so I’m quite confused

It’s me again with almost the same problem here’s preview lighting http://SSMaker.ru/c8b80a2c/ and here’s final lighting http://SSMaker.ru/578280ca/ .
I dont know how to fix overlapping textures, can anyone help me?
Link to model

Overlapping UV’s are corrected in your modelling application. In Maya you can open up the UV Texture Editor and correct any issues manually.

UV Overlapping

First toggle UV shaded display and you can see where any overlaps that are occurring by the color that the faces show up as.

dark blue means there are overlaps occuring

red means the UV faces are flipped (used when mirroring)

purple means that you are overlapping with a flipped faces (also used with mirroring)

It should be noted that I believe static meshes have been setup so that they expect no mirroring (due to lightmaps) and that if you have mirroring on your static mesh you could try creating another UV set without mirroring and set that one to be used for lightmaps but i have yet to have a look into how this is done.

As an update, out lead importing programmer has prioritized this issue.

Thanks for the update Alexander, I look forward to seeing this one, since many of my characters were rigged the same way :slight_smile:

I’d also like to point out this problem on the AnswerHub I think its got something to do with Maya groups but here’s the link to the question:

FBX Related Question

Hello. Imported this FBX into 3DS MAX from Mud Box

And the from 3DS MAX into Unreal Engine 4. It was FBX (2013) ACSII. The imported mesh looks like this.

I am probably doing something wrong, rather than it being an actual problem with the importer. If so, let me know, and I will head back to the forums. Thanks!

can you show what import options you are using? ie import normals or calculate normals

Import normals and everything is checked.