Epic Launcher wont start

HI There
have installed epic launcher but it refuses to start! Have also tried a clean install, but no luck.
Would appreciate any insights. Have attached the log file link text

Many Thanks

log is pointing toward maybe something failing to save, have you tried a different directory or with admin rights?

P9: !"C:\Program Files (x86)\Epic Games\Launcher\Portal\Binaries\Win32\EpicGamesLauncher.exe"  -SaveToUserDir -Messaging!AssertLog="Assertion failed: SUCCEEDED(Hr) [File:D:\BuildFarm\buildmachine_++depot+UE4-LauncherLive\Engine\Source\Developer\StandaloneRenderer

Hi Samboziplayz,

Try the troubleshooting steps in this section of the troubleshooting guide. Also, please try running the launcher with admin privileges.

If nothing works, follow the steps here to generate your Debug Logs. Post them here.

Hi Samboziplayz,

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue, please try the suggestion that I mentioned above then post back here with the requested info.

If you need anything else, feel free to ask.

Windows 10 fix that worked for me was putting it in developer mode.