Epic launcher will not load up

i am using windows 7 64 bit, 2 gigs of ram. i downloaded the epic launcher and installed it. when i double clicked the epic icon it asks me for permission i click yes. but nothing happens. i tried the add -http=wininet to the target and that doesnt work either.

what can i do to get the launcher to work?

Check out some of my threads and the threads I have commented on, try out few of those tips and see if it works. Mine stopped a few day ago and now it is working fine. I am not sure which tip worked because I tried them all together.

Uninstall everything related to unreal and epic launcher. Remove all the files from user/username/appdata/local/epiclauncher as well.

Use cc cleaner to remove all the traces from temp folders and registry.

reboot computer and re install.

Make sure your firewall or windows firewall has proper permissions to allow the launcher to connect.

see if this time it works.

Hi RonnieG,

Also, could you port your dxdiag (system specs)?

Go to the Start menu and type ‘dxdiag’ into the search bar. Open that file and then click ‘Save All Information’. Post that text file here.

Hi RonnieG,

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue, please provided the additional information I requested above.