Epic Launcher takes long time to start


Our issue is a little different from others experiencing this issue. Perhaps it’s a matter of patience. I found many questions posted which relate to the phrase ‘Epic Launcher stuck at Please Wait’. I thought we were having the same problem, but then I decided to do what the launcher was asking me to do. I decided to wait, and try to troubleshoot as systematically as possible:

[Case 1]

  • Start the computer from shutdown state
  • Start Epic Launcher as soon as windows logon procedure has completed and start a timer
  • Wait for Epic Launcher to finish loading
  • Stop timer, note down reading
  • Reading: 14 minutes 38 seconds

[Case 2]

  • Start the computer from shutdown state
  • Wait for HDD activity to stop post windows logon procedure
  • Perform the troubleshooting steps in this link
  • Start the Epic Launcher and start a timer simultaneously
  • Wait for Epic Launcher to finish loading
  • Note down the timer value
  • Reading: 16 minutes 49 seconds

I can update this with more cases as our development goes on, but we can’t keep doing this in particular considering the amount of time needed. But we do intend to cooperate to get this issue fixed as quickly as possible. While it does remind us of the golden days of boot times in Windows 98 and Windows XP, the nostalgia is not worth it at the moment!

Anyway, in addition to the launcher logs, here’s a little extra information:

  • Windows installed on primary disc: SSD
  • Projects and Vault stored on 3TB 7200 rpm drive [1.57 TB of 2.72 TB free]
  • Game development tools including Epic Launcher and Engine stored on an empty 1TB 7200 rpm HDD [908 of 931 GB free]
  • All discs properly optimised and defragmented using professional disc defragmenter software

Included are dxdiags, both 32 and 64 bit along with the Epic Launcher logs in zip format. If you need more information please let us know at the earliest. We can restart the launcher with debugging enabled if that helps get you more information.

Apart from the tips and troubleshooting methods, if there is anything else we can try, do let us know.

Thanks in advance for all your help and support.


Did you try any of the solutions listed here?: A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums


Yes, Fillipe. We did that in [Case 2].

Quick question guys, does the launcher have anything to do with the C drive, pagefile and Samsung Magician software that comes with the SSD?

This issue has been resolved. Please close this thread.

For those who are in a similar situation, try the following steps:

  • Use the Samsung Magician software and optimise the SSD
  • Disable the RAPID mode from Samsung Magician Software
  • Check for errors regarding your page file. Sometimes Windows 7 creates a temporary paging file. If you have 32 GB Ram, try disabling page file on all drives if none of the other applications demand it.
  • Last but not the least, wait for a Launcher update from Epic :slight_smile:

I feel like there some info missing in your solution.

You stated earlier in the thread the launcher was installed on a HDD but the solution involves the SSD? could you please confirm that the launcher is now installed on the SSD?

As that can be crucial to my trouble shooting the same/similar issue, launcher is slow at startup, is it because its installed on secondary HDD and not the main C drive (which is ssd)?

one solution:use steam instead