Epic Launcher not Locating Unreal Engine 5 after changing drive

Looking if someone would be able to help me. Have been at this for roughly 7 hours and still unable to get Unreal Engine to start downloading again or even have it locate the old download.

I had downloaded Unreal Engine 5 earlier on in the day. It takes me a while due to slow internet speeds here in Australia so has been downloading for a week. I was able to start working on a project but noticed that my C drive was running low on space so decided to move the Unreal Engine to my D drive which has over 800gb of space free.

From Then i was unable to get the Epic Launcher to recognise that the Unreal Engine had already been downloaded. I tried to route the new install to the new folder location but it said that the folder needed to be empty. So i removed the UE5 folder to my desktop and tried to start the install and then replace it with the already downloaded UE5. This didn’t work as the Launcher was unable to start downloading UE5 again and stayed in limbo on ‘Please Wait’

I Uninstalled the launcher and then reinstalled the launcher, no avail, still unable to get the download to start. Tried deleting all the WebCache’s and restarting my system, again unable to start the download. Deleted all the folders and made new one’s in seperate locations and tried to route the install into those and again still wouldn’t start a download to even try and then move the old folder into the new location. Tried to then open up the project that i had started working on. It too said unable to find UE5 location, would you like to manually locat it. Would select yes and then it wouldn’t do anything, no folder would open, nothing.

I have tried everything that i have read and still unable to get the launcher to download or get it to locate the downloaded UE5 as i would much prefer it to find this folder rather then to have another week+ to download the UE5 again.

Any help would be greatly appreciated