Epic Launcher: "Error! No version information received"

Hello,
I am receiving the “Error! No version information received” message when trying to load UE4 via the Epic Games Launcher.

If I click OK (rather than Retry) and try to login using my ID I get a second message “Error! Did not get a response. Are you connected to the Internet?” (which I am, else I couldn’t be typing in this question :slight_smile: ).

I have tried all the suggestions relating to this error on the UE4 Answerhub; including running the Launcher as an Administrator, changing my DNS settings to Google’s DNS (8.8.8.8) and OpenDNS (208.67.222.222), checking the appropriate TLS/SSL settings in Internet Options are enabled, disabling my Antivirus and Firewall (even uninstalling Bitdefender and using Kaspersky) as well as using the command line switch -http=wininet as suggested in the most recent posts regarding this issue.

Sadly nothing seems to work, any help in getting UE4 talking to the Internet would be gratefully received.

I have attached a copy of my Launcher Log File to assist in trying to resolve this.

regards

Xerxes 8933a

Hi Xerxes 8933a,

Thank you for trying the most frequent solutions and uploading your Log file. Could you also post your dxdiag ‘system specs’ as well? It will help us better track down the issue.

Windows: Go to the Start menu and type ‘dxdiag’ into the search bar. Open that file and then click ‘Save All Information’. Post that text file here.

Mac: Go to the Apple menu and click ‘About This Mac’.

Hello TJ,

Thanks for getting back to me, please find attached the output from DxDiag as requested. Hope it helps…

regards

Xerxes 8933a

Hi Xerxes,

Just curious, is the the network card build onto the motherboard or is it an expansion device?

Also, are you behind a proxy? If you are unsure, the following site should be able to tell you.

Lastly, what happens when you try to access the link below?
https://launcher-public-service-prod06.ol.epicgames.com/launcher/api/

Hello Pete,
thank you for taking time to help me…

The network adaptor is built on to the motherboard but I also tried disabling it and connecting via a USB WiFi Wireless N adaptor (just in case there was any issues with the on-board adaptor) and again had no joy in getting UE4 to connect to the Internet.

I’ve even tried going through a different ISP (via WiFi and tethering) with no luck :frowning:

The site you suggested reports that I am not behind a Proxy Server.

Finally, this is what I see when I access: https://launcher-public-service-prod06.ol.epicgames.com/launcher/api/

{
  "errorCode" : "errors.com.epicgames.common.not_found",
  "errorMessage" : "Sorry the resource you were trying to find could not be found",
  "numericErrorCode" : 1004,
  "originatingService" : "launcher"
}

Hope that helps…

regards

Xerxes 8933a

Hi Xerxes,

I’m going to log this issue in our database and ask our developers to take a look at it. Someone will be in touch as soon as we can determine where the issue is.

Also, are you by chance using IPv6?

Hello Pete,

Thank you for getting back to me and escalating the issue.

I forgot to mention that as part of my many attempts to troubleshoot and fix the problem I completely removed IPv6 from my PC using Microsoft’s ‘MS Fix It’ removal tool ( Configure IPv6 for advanced users - Windows Server | Microsoft Docs ).

It made no difference so I re-enabled it (although I don’t have or use any IPv6 addressing anyway).

Thanks for all your help…

regards

Xerxes 8933a

Hi Xerxes,

We’re investigating you issue that was entered into our database awhile ago. We’re still trying to gather information to try and figure this out and we’re hoping you might be able to help us out.

  • What country are you currently residing in?
  • Which ISP are you using?
  • Are you able to connect to the internet from other places like school or work?

-Max B.

Hello Maximumsdb3 and TJ,

sorry for the delay in getting back to you both, been a bit busy :slight_smile:

I reside in the UK and use BT Infinity (high-speed broadband from BT Internet).

Having done a few tests, I am able to connect via my ISP via a Laptop running Windows 8.1 over Wifi and via an Ethernet connection to my ISP using a PC running Windows 10 preview.

The problem occurs when using the same PC (as the Win 10 preview) if booting from the hard disk that is running Windows 7 (which is my main set-up) and I have only experienced the problem after applying the latest update 4.7 installer, I used to have UE4 running fine using previous builds and nothing else has changed on my PC.

Hope that helps…

best wishes…

Xerxes

I have the exact same problems. I started today with 4.6 coming back to do some stuff from a break, update to 4.7, tried all the steps as well, and get the same error.

The messed up thing is I was on it fine, today, and now it won’t work, same day, after the update to the engine and launcher.

Hi guys, sorry for the radio silence. Rest assure we’ve been looking into your issue. We had a Developer look into your issue and was able to find the exact error you’re getting was an incorrect SSL certificate name. The best solution for this would be to clear these certificates and then attempt to log into the launcher again.

You can find the certificates in Control Panel > Internet Options > Content tab. Click the certificates button. Go through all the tabs and delete and certificates issued by epicgames.net . This should allow you to log into launcher. Let us know if you’re still experiencing any issues.

-Max B.

Hello Max,

thanks for the response… I followed your suggestion/advice but I could not see any certificates issued by epicgames.net (or any variation on Epic Games) so there was nothing to delete.

Unfortunately, still having the same error when trying to run the Launcher.

regards

Xerxes8933a

Did you have selected for the Intended purpose and checked each of the tabs including the Intermediate Certification Authorities and Trusted Root Certification?

Hello Max,

Yes I had ‘All’ set as a filter for Intended purpose and checked all the tabs.

I even ran certmgr.msc and did a Find Certificates search for any certificate starting with “ep” across all certificate stores and in all fields (i.e. Issued By, Issued To, MD5 Hash etc.) with no success.

I have no certificates issued by epicgames.net on my Win 7 set-up (and I haven’t deleted any either).

thanks for all the help and suggestions…

Xerxes

Could you navigate to https://account-public-service-prod03.ol.epicgames.com/account/api/version in a Chrome browser and click on the little lock icon by the “https” in the navigation bar. The lock icon should be green and you should see some information about the certificate being used to authenticate the connection. Could you send us some screenshots of what you’re seeing there? From your logs it still seems like there is something either blocking the certificate check (perhaps a proxy) or the root cert is not in the trusted list on your machine.

Hello Sam,

apologies for not getting back to you sooner… unfortunately the icon you referred to when I access the page is Red.

I have attached is the screen grab you requested…

hope that helps resolve things…

regards

Xerxes

If it is showing red like this then there is definitely an issue. It looks like you are being routed to *sit2-kony.com and that is actually serving the certificate instead of us (which is why you see it as being an invalid certificate).

Running a quick WHOIS query on sit2-kony.com returns:

Domain Name: SIT2-KONY.COM
Registrar URL: http://www.godaddy.com
Registrant Name: Rajkumar Koneru
Registrant Organization: Kony
Name Server: NS-261.AWSDNS-32.COM
Name Server: NS-1740.AWSDNS-25.CO.UK
Name Server: NS-1501.AWSDNS-59.ORG
Name Server: NS-614.AWSDNS-12.NET
DNSSEC: unsigned

Does any of that info look familiar to you? Is there something about your ISP that could be causing this?

Hello Sam,

to be honest I haven’t a clue who kony.com is or why it was showing up…

However, your message got me thinking, so after carrying out a couple of thorough virus and malware scans (just to be safe) I reset my DNS bindings on the PC and router, checked the PC’s hosts file for anomalies, did a DNS flush and rebooted the router.

I’m pleased to say the Launcher now sees the Internet and I can get access to the engine/editor (still have to use the -http=wininet switch to get it to work though).

Anyway I couldn’t be more happy to have UE4 back… I can now have a proper play around with this Oculus Rift thing that’s been sitting on my desk for the last month or so :slight_smile:

Thanks to you and the rest of the staff at the UE4 Answerhub you’ve all been very helpful…

best wishes

Xerxes

Great, glad to hear it is working for you now (and that you cleaned up some of the potential malware causing this!). Do you have any details about what your malware and virus scan found? It would be useful for others that might run into a similar issue.

Hello Sam,

Just to clarify, I ran a virus/malware scan just as a precaution, in case my PC was infected with something, all the scans came up as being clean (Bitdefender, Emsisoft and Malwarebytes) so it wasn’t malware that was the problem.

I suspect the fix was probably the combination of a carrying out a DNS flush and resetting/rebooting my router…

Just glad it’s all finally working :slight_smile:

thanks again…

Xerxes