Epic Games Launcher using high amounts of CPU?

Just installed Epic Games Launcher yesterday, It was And today the problem about CPU reproduces for me. It loads my 6-core CPU to 20% (which corresponds to 100% on low-core CPU). It occurs after sleep/resume. And also after sleep/resume my account name appears with red dot as though I am not logged in (and only Sign In in drop down menu). Perhaps I will not use launcher anymore, and my post here is just to notice that not all problems in launcher are solved yet.

Hey all,

We are currently working on another Launcher release with additional CPU and memory improvements. Keep an eye out for it next week.

You two may have found a bug with hibernation that we’ll investigate.


I noticed this too, but only when it was not minimized.

This bug happened to me today which is why I’m typing this post. I’ve never hibernated this PC (pretty fresh install), only put it to sleep a few times. It was taking up two full cores all of the sudden. Thinking back, I remember the little colored dot by my name & balance was red when I closed it for misbehaving.

Anyways, thanks, I will be looking forward to the performance fix.

Same thing happening to us also, on multiple machines. I hope this is fixed soon. The biggest problem is the launcher wants to run in the background (e.g. suggests to minimize to tray, opens by itself with other applications sometimes, etc.) and the only solution to keep our system from paging all the memory out is to change the name of the launcher executable (as mentioned earlier in this thread). This should be a HIGH priority fix as it seems the Launcher is a central component of the Unreal engine infrastructure. What is amazing is that the Launcher uses more CPU/RAM while sitting idle than does the actual editor during (albeit minor) editing of a project!

Thanks for your help on this!

To me in Windows 7 use about 300MB or more of RAM all the time

I’ll add my screenshot to the mix:

Minimizing it brings it down to 23% which still seems absolutely crazy… What is causing this and what is the progress on actually fixing it?


It got worst, the launcher is now freezing my cpu and ram for a while when starting the thing.
Background use is not only affecting Ram and Cpu but also Editor Framerate and Assetloadtime.

I understand that the unreal engine is not for weaker systems but a launcher that takes almost as much ressources as a project is just… Who thaught it was a good idea to start that thing every ****ing time?
Or minimizing it? Why should minimizing help, it still takes alot of ressources. You guys should really build a better launcher XD

Like one that does not auto logs you in so i dont need to wait 5 minutes for that thing to unfreeze. JEZUS

What’s the Launcher developed with?

i just found in launcher setting “enable minimize to system tray”
by doing so, after opening launcher and launching my project from library i just minimize the launcher and high CPU usage is gone! yay :smiley:

Man, never before have I faced this kind of problem, then I just had updated my windows this problem showed up, I totally desperate