Epic Games Launcher stuck on "Please Wait" when downloading Unreal Engine 4.8


I am having problems installing Unreal Engine 4.8

I have tried the following:

  • Running Launcher as an Administrator
  • Changing my DNS to those suggested in troubleshooting
  • Open Launcher with “-OpenGL” parameter
  • Open Launcher with “-http=wininet” parameter
  • Opening port 5222
  • Disabling my firewall entirely

None of the above have worked.

I have attached a (Log file) generated while debugging was enabled.

Can you please let me know if there is anything I am doing wrong, or anything else I can do to move forward.


I managed to move forward by un-installing the Launcher. Restarting. Reinstalling the launcher. Restarting.

After this the Launcher no longer attempted to download Unreal Engine 4.8, but instead showed 4.8.3. Download seems to be in progress.

Not sure if this was just coincidence or not, but it seems to be resolved.

Hi everyone,

For anyone else having this issue. Give the workaround posted here a try. Let us know how it goes.



Hello.The problem actually is the internet. why you should be slow , so try to put another port . I waited a long time and after a time returned to normal , wait 15-30 minutes can return to normal :slight_smile: . If you get error code 5 , reinstall the progam completely