Download

Epic Games Launcher stuck at "Please Wait", constantly downloading something

I’m on Windows 7 x64 and using the latest Epic Games Launcher.

When I launch it, it says “Please Wait”. According to a bandwidth monitor, it’s downloading something.

My internet connection is slow (< 0.5 Mbps) so you can imagine it takes a very long time to download anything.

Since there is no progress bar, I don’t know what it’s downloading, or how long it might take to complete.

So my feedback is:

  1. Never download anything without a progress bar or at least an indication of download size.
  2. Think of the people with poor internet connections. Not everyone can download hundreds of megabytes on each launch.

I have slow internet also. (80kbs a sec…)

The longest it took for the Please wait to go away was around 15-20 minutes.
Just sit back and wait I guess… Then it should let you in.

And if nothing happens 30 minutes in, you might have a problem. (Also, it doesn’t download hundreds of megabytes usually. The real big stuff comes with downloading the engine or a Game.)

Found this too, automatically downloads updates instead of asking to begin with. It’s really annoying when you are using a PC without admin rights and have to wait for the update to download and then fail installing before you can login or go offline mode.

Hi everyone,

I’m sorry that you are having an issue with the Epic Games Launcher. In order for us to offer the best support, we have recently modified the process for how Epic Games can help troubleshoot your Launcher issue. Please visit http://help.epicgames.com/ for technical support, here you can find information and solutions for common issues, as well as a contact form if you still need additional assistance. Thanks!

Hi, I also have this problem, the best thing to do is to create a direct link to the Unreal Editor, it will be somewhere like C:\Unreal Engine\4.10\Engine\Binaries\Win64\UE4Editor.exe .

Hi, I am also having problem with the launcher.
I can not download any version of the engine except the marketplace or any utility!

You do realize that you can turn off auto-updates by clicking the gear button in the top right, scrolling down, and turning off auto updates.
Quit your bitching

There are two things that this could be:

  1. A full destination HDD.
  2. Running existing editors with that specific project version, in the background. If you close all opened UEs of that version and try to enable add-ons, it will start downloading.

I know that’s not your exact scenario, but there is not much else to post my findings about having a stuck Epic Games Launcher–download “queued”–when enabling “Editor symbols for debug” on a specific engine version.