Download

Epic Games Launcher Quitting Unexpectedly

Hi everyone, wondering if you could help me resolve an issue I’ve been having lately. I tried opening the Epic Games Launcher today, and it opened fine. In the little download box in the top right corner it showed that it automatically was downloading a new installer or version or something which was fine - I hadn’t opened the launcher for a couple months so a little update makes sense. So then it says to restart the launcher to apply the new update, so I do, but I can’t get back in now - every time I try to open the launcher my mac posts the “Application Quit Unexpectedly” message. I also tried redownloading the launcher, but it doesn’t work either. I’m not really sure where to go from here, any help is greatly appreciated.

Note for mac users, if you can check your LaunchAgents and LaunchDaemons folders to check if there are any uneditable plist files for UE4 that would be handy - had to delete some and may have accidentally deleted an important one for this. Though I feel like that would be re-created when I downloaded the launcher again.

Hello I am having similar problems in my PC. Also coming from a very similar situation. Hope to get an answer soon. Good luck.

I am having a similar problem as well (on mac). I just created an Epic Games account today hoping to download the engine and try it out, and after opening the launcher the download bar went to 100% and then the launcher quit unexpectedly. I also don’t know where to go from here and would greatly appreciate some help.