Download

Epic Games Launcher not working with NVIDIA Optimus

Hello,

I’ve notice, that the epic games launcher is not working with nvidia optimus technology. I’m using a notebook with two graphic cards (Intel HD Graphics 4600 + NVIDIA GeForce GTX 760M [notebook: P34G from Gigabyte]). When I’m starting the launcher, it’s crashign immediately (task manager says “inactive”). Nothing happens.

When I disable the NVIDIA graphic card or change the configuration for “epicgameslauncher.exe” in the nvidia control panel, to use the integrated graphic card (intel) instead of nvidia it works without problems.

The same problem applies to UnrealTournament v. 4.7.4 (and below). I can’t run this game on my nvidia card. It’s only working on Intel HD Graphics, where it runs on minimal details but I would like to play it on my dedicated NVIDIA card. Can you fix this issue?

I’m using latest nvidia drivers (350.12)

Here is a video that shows the problem: https://www.youtube.com/watch?v=Fkm64JWJVIM

With my ROG, I just made the GPU the primary video card, bypassing the integrated card. Don’t disable the Intel graphics, as the HDMI still requires it.

Yes, when I disable the nvidia card, it is working, but then the games launch with the intel card (it’s not possible to make the nvidia card as primary card). I want to use my nvidia card for UnrealTournament.
Another solution I got from someone in the Nvidia forums (https://forums.geforce.com/default/topic/826438/pc-games/epic-games-launcher-not-working-with-nvidia-optimus/) is to add “-OpenGL” as parameter to the epicgames launcher. This is working for the launcher, but when launching unreal tournament from the launcher, I only get a black screen and the process dies via nvidia card.

One interesting fact about this problem:

I have two displays (laptop display + external connected via HDMI). On the second display I have the task manager running. Now, when I start the game by clicking “Launch” from the launcher, it starts on the first display. When I immediately click on the task manager (make the task-manager window as active window), the main menu shows up on the first display.

As soon as I activate the unrealtournament window, it’s getting completly black and nothing is shown. The process crashes.

And this is what it looks like:

https://www.youtube.com/watch?v=k4jaAugDWQc&feature=youtu.be

And here is the UT logfile: http://pastebin.com/2DG1sdSJ

bump…

Hey TDO - Thanks for the report, Can you post it over in the Bug Reports section on AnswerHub? That way, we can properly track it!

Thanks a lot

I’ve just created a thread there: UT not working with NVIDIA Optimus - UE4 AnswerHub

But I don’t really think they can help me, because someone with an equal problem created a thread on the AnswerHub and was directed to the unrealtournament forums, to get an answer (https://answers.unrealengine.com/questions/188412/epic-game-launcher-freezes-at-start.html ). There no one replied to his thread and was left alone with it (https://forums.unrealtournament.com/showthread.php?16830-Game-crash-at-start-if-I-do-click-somewhere-with-black-screen ).

Don’t know, if Epic Games / UT developers don’t care about this problem, since only 2 people are getting this issue right now (I think there must be much more, because more people are using gaming laptops with two GPUs)…

Hi TDO,

Have you tried the solutions listed on the launcher troubleshoot page? Can you specifically try the -OpenGL command? Several users with integrated, or laptop specific graphics cards, that experience the issue you’re having were fixed by using that command. Let me know if that works!

-Max B.

Please see post #4 above in this thread. The -OpenGL fixes the issue with the launcher, but UnrealTournament still does not work on nvidia card. And since UT is started from the launcher, it might still be a launcher problem…

It is if you are using the Nvidia Control Panel. Here is a screenshot of what to look for to make the modification.
2015-04-27_13h06_14.png

Yes, I know. This is already set to NVIDIA high performance card. But with this configuration, UnrealTournament does not work correctly. I get the mentioned black screen and the game crashes as shown in the video above.
To make the game work, I have to change this configuration to Integrated graphics. Then the game works and I can play, but only on minimum details, because the Intel integrated graphics card is not very powerful.

Then it sounds like something is screwed up with your drivers, or the install of the Control Panel. Does the laptop company have a forum? I’m wondering if other people have similar issues as yourself with other games, and may have posted there.

I’ve already completly re-installed my nvidia drivers. Other games are also working fine with the nvidia card (but I had the same error with the game “Emergency 5”. It only worked on Intel. I told the developers and they brought out a patch, which supported Nvidia Optimus technology. Then it was working fine. The same error happens to GTA V, lots of people have this issue too. The developers are aware of it and currently working on a fix for that).

So, I think the developers of UnrealTournament or the Epic Games Launcher have to do something, to make the game work with Nvidia Optimus, switchable graphics to make the game run on nvidia graphic card and not only Intel integrated.

There is someone else on the UT forums having the same issue: https://forums.unrealtournament.com/showthread.php?16830-Game-crash-at-start-if-I-do-click-somewhere-with-black-screen
His hardware is Intel(R) HD Graphics 4600 + NVIDIA GeForce GTX 870M. Which is equal to my configuration (Intel HD Graphics 4600 + NVIDIA GeForce GTX 760M).

I noticed, that when I add this line:

FullscreenMode=2

in the file “C:\Users-Username-\Documents\UnrealTournament\Saved\Config\WindowsNoEditor\GameUserSettings.ini” the game is running in window mode and it’s working on the nvidia card. Everything is okay (except that it is in window mode).

When I switch to fullscreen mode, only a blackscreen occurs and the game crashes.

So last night I installed the latest alpha of UT, on a ROG laptop with HD Graphics 4600 + NVIDIA GeForce GTX 870M. I had no problem getting the game to running, so I’m trying to figure out where we can look next for your problem.

Just posting to say I’m having the same issue with launcher and Ashen. Intel and nvidia for me too.

Won’t open or crash with nvidia, works, but chopping on low settings with Intel. (I’ll also do bug report.)

Try right clicking the icon for the launcher or the editor, run with high performance.