Epic games launcher not starting

Hi, so i just got done installing the launcher from $17,000,000 of Paragon content for FREE - Unreal Engine. Everything during the install was smooth and no errors happened. Now when i try to start the launcher it doesnt show up, and in task bar its running. Before i start reading the same old troubleshooting stuff please allow me to shut some of you down. I have ran it as Admin, Added -OpenGL, gave the launcher all permissions, restarted the computer after every change, added -http=winnget or something like that? I cant remember that exact command off the top of my head but i did it. I tried to find the Epic games launcher and the unreal engine launcher in the Epic Games Folder, and was only able to find the Epic Games Launcher. The only thing in the specified location for where the unreal engine should be is the crash report app. Now to give everyone my specs here we go! Im running a brand new MSI GE62 6QF Apache Pro which consists of a Nvidia 970m, i7 clocked at 3.2Ghz, and 16GB of RAM. My graphics card is always up to date, and its running the latest DirectX 12, and the latest Microsoft framework .net 4.6.2. I’ve tried repairing the launcher, and everything i could find so far and absolutely nothing has worked.
So please someone on windows 10 tell me what the deal is Lol

The launcher has still failed to fully run. Itll download whatever it needs to function, and then it stops showing or loading anything else. This is not solved, the launcher is still corrupted, the launcher will still not work.

Hi ToF,

In order for us to best support you, we have recently modified our process for how we handle Launcher issues.

Please visit: http://help.epicgames.com

Here you will find information and solutions for common issues, as well as a contact form if you still need additional assistance.

Thanks,

TJ

Correction: that doesn’t help and I’ve been discussing this through your support email team for days and nothing so far

Try reinstalling the launcher as admin

Cant. My computer has that option missing by default. Tried adding a custom registry to do so and it never changed anything