Epic Games Launcher not loading

So basically, when I try to open EpicGamesLauncher, it will only appear in my Task Manager, but otherwise it doesn’t show up at all. Also, I’m using readyboost (all 4 gb of external ram) on a thumb drive, so I don’t know if ram is the problem here, unless the program just doesn’t care about external ram.

link text

Hi Esmith,

Try the troubleshooting steps in this section of the troubleshooting guide.

If nothing works, follow the steps here to generate you Debug Logs. Post them here, along with your Dxdiag (system specs).

My dxdiag is already in the OP. Here’s the Debug Logs:

link text

I tried those troubleshooting steps, and it still doesn’t work. In fact, when I try to add -OpenGL to the target path, it crashes (I know this because I have task manager open, since the crash client doesn’t show up either). Also I recently updated my video card’s driver, so I don’t know if that’s the cause.

Hi ESmith1,

Sorry for the slow response, thank you for providing your logs. Unfortunately due to the nature of your crash they are giving us very little to go on.

I was hoping to get a little more information from you. What would really help are some crash reports, from what you’ve said I take it that the crash reporter does not show up at all?

With your logs you provided a single crash dump, are there any other folders in your log file which match a similar description?


Yes, here they are. It crashes when I add -OpenGL in the properties.

link text

Hey ESmith1,

After inspecting your DXDiag it seems you have out of date graphics drivers. Can you please update your graphics drivers to the latest recommended drivers for your device.

You should be able to find what you need using:

I did that, and the only thing that change was the amount of CPU the program used. Prior to the update it was using around 15% consistently, now it just goes up to 6-10% and then goes down to 0%, occasionally going up to 0.1% and then going back down again (I have task manager open, since I still can’t see the program).

Hey esmith1,

Sorry for the delay, we’re currently trying to reproduce the problem so we can find a solution for you. We’ll get back to you as soon as we have some more information - hopefully very soon.

Hi esmith1,

Sorry for the delay. Can we get an updated copy of your DXDiag just to confirm the driver state.

Can I also get you to provide a log generated from a application called procmon, follow these instructions:

1.) Please download Process monitor from this link: Process Monitor - Windows Sysinternals | Microsoft Docs

2.) Open the zip file you download and move the Procmon.exe to somewhere on your machine.

3.) Right click on that executable and select run as administrator.

4.) When the application launches go to the menu bar at the top and select “Filter” then select “Filter…” from the menu that pops up.

5.) In the window that opens select the top left drop down and change it to “Process Name”

6.) The drop down next to this should read “is” this is correct.

7.) In the text box to the right of that enter “EpicGamesLauncher.exe”

8.) Then click the Add button and then click OK

9.) Now run the launcher.

You should see the window in the process monitor start to fill up. Once you have seen the error window show up from the launcher dismiss the dialog and go back to the process monitor and follow these steps:

1.) Go to the top left menu and select “File” then “Save…”

2.) A Save To File dialog will appear, the default settings are what we want. They should be “Events displayed using current filter” and a format of “native process monitor format”.

3.) Check the file location and press Ok

4.) Find that file on your PC and upload the file here (You may have to zip the file up)

Tried the process, error window didn’t show up. Also, for whatever reason, I can’t post attachments to this post (or any other post for that matter), meaning I can’t post my DXDiag file. I guess I could copy the text in a file and post as a reply if you want.

Tried the process, error window didn’t show up. Also, for whatever reason, I can’t post attachments to this post (or any other post for that matter), meaning I can’t post my DXDiag file. I guess I could copy the text in a file and post as a reply if you want.

Hi esmith1,

We were experiencing an issue with the AH posts last week. Could you please try reposting your dxdiag now? If it still does not work, please let us know and we’ll find an alternate way to get the information from you.


link text

Hi esmith1,

Now that you can post logs again, could you try to obtain the Procmon logs again that Barnabas request?

Yeah, tried to run it with, and without openGL, and the error window never came up. In fact, nothing came up in the procmon either. It just keeps filtering events, and that’s it. I waited until it filtered about 4 million events until I just gave up on it. Not sure if I’m doing something wrong or not.

Hi Esmith1,

Ok, thanks for the information. Your issue has been reported as JIRA OPP-4583. I’ll update you once I have additional information.

Hi esmith1,

Sorry for the delay. If task manager is showing that the launcher is running, then procmon should produce entries related to it.

could you please do the following so that we can continue to invesitgate the issue?

  1. Provide a screenshot of the filter settings in procmon. (up to step 8 in the process that Barnabas provided above)
  2. Provide a screenshot of your task manager running both procmon and the Epic Games launcher.

Also, make sure that procmon is running prior to starting the launcher.

Ok, here it is.

Hi esmith1,

Ah, I see. Remove the entry for epicgameslauncher.exe then re-add it without the quotation marks. This should resolve this procmon issue and allow it to be displayed properly.

Hi esmith1,

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue, please try the suggestion that I mentioned above then post back here with the requested info and I’ll update your Jira report.

If you need anything else, feel free to ask.