Epic Games Launcher Installation Error with Directx

I am unable to install the Epic Games Launcher. Whenever it comes to the “install DirectX” step it shows me an error message, something like “problem with a Windows install package” and does a rollback of the installation.
I have made sure my DirectX and the MS redistributables are all installed and have the latest updates. My PC has installed the latest Windows 10 updates, and my graphics card is also up to date.
I would like it installed on my HDD drive which is not the C:\ drive, but it does not make a difference anyway. I tried installing it on both drives, same error, no matter on which drive the .msi file is located or on which drive I am trying to install it.
I have also tried disabling my antivirus software for the duration of the installation. I have never had MacAffee on my PC. I have tried every fix I was able to find before posting this question.
Here are my installer logs and my dxdiag.

same for me (Windows 10, OS Build: 16299.214), is there a way to force the installer to ignore DirectX issues

d90d5f9b46de031a8c5378a3c146b625

Issue seems to be trying to install DX11 on Win 10.

You can get the DX Install to “Pass” by deleting all the files from the DX Install folder other than the .dll and .exe, but I haven’t found a way to do this when using the .msi installer for the epic game launcher.

I am able to do this for the stand alone DX install and that works fine.

i have the same problem. My pc is up to date and i have all directx updates. I sent a mail to player support at least 2 weeks ago didn’t get a answer.Also i started a question but it recieved no answers.
I just wanted to play a game but it’s been weeks and i still couldn’t get a answer.

Oh, so I was able to get it to install by editing the msi installer and removing the instruction to run the DX installer. It’s not the best solution but it worked enough to get the launcher to install. That said, once the launcher has installed it failed the Self Update so it was all a waste of time for me and I’ll just end up doing what I should have done in the first place and forget Fortnite and get PUBG.

But either way in case it helps anyone else, below is the link to the edited msi I created and the steps to edit yourself if you don’t trust some random person’s msi installer out on the net (and you shouldn’t!).

Lazy Link: MEGA

Steps

  • First you’ll need to download [msi2xml][1] and [Notepad++][2] (recommended).

Download the latest installer (for me it was epicinstaller-7.2.1.msi) and save it to an easy location on your computer (eg *C:\Working*).

  • Now extract the msi2xml files to the same location.

  • Open a Command Prompt (Start → Run → cmd) and change the directory to your working folder above.

List itemNow run the following command:

msi2xml -c (outputFolder) (msiInstaller)

msi2xml -c xmloutput epicinstaller-7.2.1.msi

  • Once this is finished, use Notepad++ to open the xml file that was created in your working folder (it will be named the same as the msi installer, so for me it was epicinstaller-7.2.1.xml)

Now find and delete the following from the xml file,

230125-textwontpostproperly.png

Edit: This site screws with the formatting so I’ve posted a picture of the code

(again for me it was on lines 43510 to 43516)

Once that’s done it should look like this:

Save and close Notepad++.

  • Now back on the command prompt enter the following command to rebuild the msi,

xml2msi -m epicinstaller-7.2.1.xml

Once that’s done you should be able to use it to install.

Of course I now get another error and I’m giving up on Fortnite. PUBG it is.

230124-updatefailed.png

I tried your method but after using the xml2msi command, the new .msi file returns this error upon executing it. It says something about an error with transformation paths. I am not sure what transformation paths are.
Curiously enough, I get the same error when using the file you provided.

found a way to fix DirectX so one can use the original EpicInstaller

  1. Start Menu → type regedit
  2. go to
    Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DirectX
  3. double click Version
  4. change “Value data” to 4.08.00.0904
  5. do the same for
    Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\DirectX

the EpicInstaller should work now, or after a restart

This worked! Thank you!

Follow up questions:
Why does this work?
How is it you found a solution and Epic does nothing, not answering tickets, nothing?
And how will this affect other games or DirX updates in the future?

:slight_smile: no prob

think it works because it allows one to overwrite a faulty DirectX installation by making it read that you have an old version of DirectX

i’m an indie developer considering using Unreal Engine for a new game, but now i’m thinking i’ll just stick with the Unity game engine

i’m hoping that future updates will work as they should now, but i’m not sure why something went wrong in the first place so i guess it could just happen again; think it might have something to do with the Windows 10 upgrade process…

Genius! Totally worked! :smiley: THANKS!!!

worked fine !
GG

Worked for me too. Thanks, bro! <3

I got the same error while installing EpicInstaller-7.7.0-unrealengine .
maybe, permission on selecting FULL CONTROL is not enough for my case.
After trying the solutions from forum, it looks fine by these steps.
(I guess… maybe it’s fine now ?)

Thank you!

I tried a number of other solutions, including trying to resolve installing the DirectX redist directly and trying to resolve the errors coming out of that to no avail. This was the only way to get the Launcher installed.
During my attempts to fix the issue with DirectX I discovered I had the June 10 Redist on a lot of install folders for Steam games and none of them attempted to install it - I assume because of newer versions of DirectX having been installed, which leads me to wonder why Epic didn’t make the DirectX install for their launcher optional if a newer DirectX is installed.

Again, thank you! Your solution was the only one that works for me.

What do you do after step 5?

hi, the EpicInstaller should work after step 5, or after a restart

Is it like this? because when i did it it didnt work

must be another issue, sorry, almost certain this won’t make a difference but my
(Default) string data is (value not set)
which can be done by right clicking (Default) and clicking delete
which sets it back to its default (value not set)

Thank you!!! It worked! After the installation of the client, is it possible to return the number in Version as before? Or we have to keep those number changed?