Epic Games Launcher crashes when I try to download (Mac User)

My Epic Games Launcher wont stop crashing at the second it finishes installing and I have enough space for it to download
I tried deleting it and then reeinstalling, I tried restarting my computer but nothing worked
I have no idea what is happening.
Here is a screenshot of the error report.

I don’t know how to fix a bug like this and it has happened more than a few times.

Try this: Instead of opening the app, find it in finder instead, right click on it, click “show package contents”, then open the folder “contents”, go into the “MacOS” folder, and open the “EpicGamesLauncher-Mac-Shipping” exec file. That has worked for a couple people!

It doesnt work. Please see below:
AMRITANSHUs-MacBook-Pro:~ amritanshu$ /Users/Shared/UnrealEngine/Launcher/SelfUpdateStaging/Install/Epic\ Games\ Launcher.app/Contents/MacOS/EpicGamesLauncher-Mac-Shipping ; exit;
2018-10-17 22:29:32.768 EpicGamesLauncher-Mac-Shipping[5294:550897] Fatal error: [File:/Users/build/Build/++Portal+Release-Live+Full/Sync/Engine/Source/Runtime/Core/Private/Internationalization/ICUInternationalization.cpp] [Line: 135]
ICU data directory was not discovered:
LogMac: Error: appError called: Assertion failed: [File:/Users/build/Build/++Portal+Release-Live+Full/Sync/Engine/Source/Runtime/Core/Private/Internationalization/ICUInternationalization.cpp] [Line: 135]
ICU data directory was not discovered:

Abort trap: 6
Saving session…
…copying shared history…
…saving history…truncating history files…

[Process completed]

Is your system within the Recommended Hardware and Software Requirements?
macOS 10.14 Mojave, Quad-core Intel, 2.5 GHz or faster, 8 GB RAM, Metal 1.2 Compatible Graphics Card, latest Xcode.

I’m having this exact same issue. Everything is completely up to date and proper. I have no issues with any other applications.

Hello guys, I had this same issue today and all i had to do to fix it was to download and install the new Mac OS “Catalina” just upgrade your OS and the launcher should work just fine!

i don’t know reasons. But it helped me. I was just use terminal, copied application from dmg a like this http://commandlinemac.blogspot.com/2008/12/installing-dmg-application-from-command.html.

And run louncher through “open”.

 open /Applications/Epic\ Games\ Launcher.app

Inside Launcher install and open Unreal Engine

me too i have a mac mini and the UE4-EpicGamesLauncher error keep popping up when i open epic

Cycling/ searching through the Epic site fails to reveal the current MAC operating requirements, for either UE4 or Epic Games Launcher. Are these posted anywhere? My Install keeps failing too - running OSX 10.11.6 El Capitan

man, it works. thank you.

Yeah! just tried launching using EpicGamesLauncher-Mac-Shipping and so far no crashing! hope it stays like this.

For anyone else who runs into this question I tried INFJwithaNiFe’s answer and though the crash still happened the logs showed me a clue that it was having trouble with creating a Chromium window. I opened Safari and made that my default browser instead of Chrome, re-ran the launcher and it worked properly.

Awesome! It works!