Epic Games Launcher cant connect to server

My launcher is checking for updates, then error cant connect to server, click ok and try to sign in, error again cant connect to server.

It was working prior to a defrag I did a few days ago? I also had to rearrange the data on my hdd using a partition tool. Could this be the cause?

EDIT: I have uninstalled the Epic Launcher and deleted the Epic folder on my drive. Ive run CCleaner on my registry, rebooted. Now when I try to reinstall the entire thing and start from scratch the installer gives me the option of repair or remove. How do I remove UE4 from my computer??? I have tried IOUninstaller and also through running the installer and choosing remove. Ive even deleted the root folders!?

Fixed. The problem was a firewall issue. I have ZoneAlarm installed but I had it disabled in startup programs. So my windows firewall was kicking in but was not set up to allow the launcher through.

Solution:

  • Started ZoneAlarm
  • Restarted launcher
  • Allowed the launcher exe through the ZoneAlarm firewall.
  • Works fine now.

I changed my DNS, added -http=XXXX to the shortcut launcher, reinstalled the launcher loads of times, checked SSLXX, TLS XX in internet options…nothing worked. Check your firewall first if there is a connection issue!!.

Now to finish my game :slight_smile: