Epic Games Launcher can't be opened (Macbook pro 2015)

Hi Everyone,

I have a Macbook Pro (early 2015) with OS X El Capitan. I opened the Epic Games Launcher yesterday in time for the Epic Game Jam this week to update the launcher and download Unreal 4.9. It updated successfully but today I have been unable to open the Epic Games Launcher. I receive the message “Epic Games Launcher can’t be opened.”

I “allowed apps download from Anywhere” in the Security and Privacy settings, as recommended by similar posts. I have also restarted the computer and reinstalled the Launcher, but none of these have worked.

If anybody has any input, it would be greatly appreciated.

I got the same problem,!
Macbook Pro 15(Retina,15-inch,Mid 2014) with OS X EI Capitan
Can anybody help???


Hi k0olah,

I apologize for the delayed response.

To begin with, could you try the troubleshooting steps in this section of the troubleshooting guide.

If nothing works, follow the steps here to generate you Debug Logs. Post them here, along with your Dxdiag (system specs since you’re on a Mac)…

So after a couple restarts, it “magically” worked. I’m honestly not sure what fixed it.

eseedo, one thing you could try that other forums have recommended is to go to Preferences > Security & Privacy > General and select “Anywhere” for the "Allow apps downloaded from: " section. Although I had this selected, it didn’t work for me in the beginning, but like I mentioned, after a couple more restarts it just magically worked.

Posting here for a lack of where to post. It looks like the Epic Games Launcher app on OS X is built from broken code.

Actual error:
11/12/15 11:59:24.375 AM com.apple.xpc.launchd1: (com.apple.xpc.launchd.oneshot.0x10000014.UnrealEngineLauncher-Mac-Shipping[36487]) Could not find and/or execute program specified by service: 2: No such file or directory: /Applications/Epic Games Launcher.app/Contents/MacOS/UnrealEngineLauncher-Mac-Shipping
(emphasis mine)

You can see that should have been fixed by this commit

I don’t think there’s a pull request I can make to fix this, I think it needs to be cherry picked into whatever branch the download link version is built from and rebuilt. I’m checking out the UE4 source and I’ll build it myself to see if that fixes it.

Or… there’s some weirdness with launchctl having a cache of that name for the oneshot daemon. Which explains why the “answer” post claims it works after a few restarts. I’ll keep digging.

I have that same problem. But it doesn’t magically starting to work…

Hey guys,

We noticed a problem with the Mac installer and have just completed a fix and pushed it to the website. You’ll need to download the new DMG from the site and that should fix you right up.

Sorry for the inconvenience!

same here - no solution found yet.

MacBook Pro (Retina, 15-inch, Late 2013)

I just ran into the same problem today. I downloaded the DMG from the site again but that didn’t fix it.
Running from the terminal shows this error message:

LSOpenURLsWithRole() failed with error -10810

Directly running the executable inside the app bundle works.

Hi Hcenteno,

I apologize for the delayed response. Thank you for the information. Can you follow the steps here and send me your system information?

The issue has been reported as JIRA OPP-4814.

Hi Steve. The issue is still there. I downloaded the launcher yesterday (December 1st) and it doesn’t open.

I found a way to circumvent this.

Go to the applications foldes and find the epic launcher.
Right click → Show Package Contents.
Go to Contents → MacOS and run/open EpicGamesLauncher-Mac-Shipping

It will start and it will update allowing you to use Unreal Engine.
(I will add if the launcher works upon close after the install of the latest engine)

Edit: The launcher does not work after close (osx says it is damaged and should be sent to trash) but if you repeat the process stated at the beginning it will start again.

Hi Phreakii,

Can I confirm that you have followed Steve’s instructions above to download a fresh version of the DMG?

Hi lqlwle ,

Can I confirm that you have followed Steve’s instructions above to download a fresh version of the DMG?

Hello! The issue is still there. Downloaded the installer Mac on Jan 6, 2016. I did the suggestion above and the launcher loads (with a terminal window open).

I also tried opening the Launcher from the dmg installer and it works fine. It only fails to load when it’s run from the Applications folder

As there’s been no response, I’ll mark this as resolved for the moment. Anyone struggling with running the Unreal Engine Launcher on Mac should open up a new ticket for further support from Epic by visiting http://help.epicgames.com/ for technical support. Here you can find information and solutions for common issues, as well as a contact form if you still need additional assistance. Thanks!.

I can confirm i downloaded a fresh copy from unreal website today Jan/15. EpicGamesLauncher-2.8.3-2819560.dmg I get the same screenshot as above “The application “Epic Games Launcher.app” can’t be opened”