Epic game launcher stuck

When I launch the epic games launcher it get stuck like this and cannot access anything. Already tried to uninstall and install again but it didn’t work, help please.

Try to revert to the old launcher then.

You could get the unreal source from git hub. https://docs.unrealengine.com/en-us/GettingStarted/DownloadingUnrealEngine/GitHub

Are you using Mac OS and with your system’s primary or secondary language of either Russian or Polish?

If so, this is a known issue that will be resolved within a day or two. Apologies for the inconvenience.

Mac OS but only language using is English

I have the exact same issue, the update ran, restarted and now its toast,. MAC OSX SIERRA 10.13.6, English.

Click the small prurple image (fortnight), then click the tiny yellow rectangle on the top right, and it works!

We have just released a launcher update (version 9.3.0-4632729) which should resolve UI issues for Mac OS.

Please let us know if the issue is resolved after you update the launcher.

I have the same

Yes it solved the problem, thanks for the help.