Epic game launcher not starting

Every time I try to run the Epic Game Launcher I see the process start in the task manager but nothing else happens. I’ve tried everything in the troubleshooting guide (A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums) and still no luck. I’ve atached the logs and the dxdiag link text Please help.

Hello dxvii,

I’m sorry to hear that you are having trouble. Based on the information you sent, it appears that it might be a graphics driver issue. Could you please visit the AMD website and try to update your drivers to the most recent version?

Thank you for the response. I’ve used the automatic detect and install software from AMD and it says I am up to date. But just for good measure I found latest the software and drivers on there web page for my graphics card and reinstalled. Still no luck. I’ve even tried reinstalling the Epic Games Launcher after the graphic card reinstall. Nothing seems to work.

Hi dxvii,

Could you please try the following?

  • Close the launcher.
  • Navigate to the launcher log folder and clear out the files there.
  • Follow the steps here to generate your debug logs from outside the launcher.
  • Attach your newest launcher logs and dxdiag.

Here are the new Logs and DxDiag

Thanks again!

Could you try one more thing for link textme? Please follow the steps here and add the “-http=wininet” command to your Epic launcher target line.

In addition, could you please try the steps here and add “-opengl” to your target line as well?

Post back with the results, please.

Still no luck…
Logs_and_DxDiag_wininet.zip
Log_and_DxDiag_OpenGL.zip

Hello again!

One more thing. I noticed that your launcher may not be running with admin privileges. Could you please right click on the launcher icon, select “Run as Administrator” and try again?

There is only a Win32 folder.

Target: “E:\Program Files (x86)\Epic Games\Launcher\Portal\Binaries\Win32\EpicGamesLauncher.exe” -debuglogging

Hi Dvii,

Sorry, apparently I didn’t edit my reply fast enough. Please check above.

about the same as before… run_as_admin.zip

Hi dxvii

Can I also get you to provide a log generated from a application called procmon, follow these instructions:

1.) Please download Process monitor from this link: Process Monitor - Windows Sysinternals | Microsoft Docs

2.) Open the zip file you download and move the Procmon.exe to somewhere on your machine.

3.) Right click on that executable and select run as administrator.

4.) When the application launches go to the menu bar at the top and select “Filter” then select “Filter…” from the menu that pops up.

5.) In the window that opens select the top left drop down and change it to “Process Name”

6.) The drop down next to this should read “is” this is correct.

7.) In the text box to the right of that enter “EpicGamesLauncher.exe”

8.) Then click the Add button and then click OK

9.) Now run the launcher.

You should see the window in the process monitor start to fill up. Once you have seen the error window show up from the launcher dismiss the dialog and go back to the process monitor and follow these steps:

1.) Go to the top left menu and select “File” then “Save…”

2.) A Save To File dialog will appear, the default settings are what we want. They should be “Events displayed using current filter” and a format of “native process monitor format”.

3.) Check the file location and press Ok

4.) Find that file on your PC and upload the file here (You may have to zip the file up)

Here is the log file you requested. Logfile.PML.zip But I never actually see an error, I don’t see anything happen. The process opens and runs but then just sits there using 0% processor and 30.8MB of memory. I let this log run about 5 minutes after the processor when to 0% on the EpicGamesLauncher.exe process.

Hello dxvii,

I have created a jira ticket for your issue under OPP-4941. As soon as I have an update, I’ll reply back.

Hi dxvii,

I apologize for the delay. Your issue is still being investigated. I was asked to confirm that you are NOT using the graphics processor built into your CPU. If you are not using it, could you please disable it? Suggestions on how to do this can be found here.

Hi dxvii,

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. Your JIRA ticket, however, will remain open. If you’re still experiencing this issue, please try the suggestion that I mentioned above then post back here with the requested info.

If you need anything else, feel free to ask.