Enum Output In Macros Not Working


Currently in 4.10 Preview 4, macros can’t have Enum outputs connected to Enum variables. Here are the steps;

  1. Create a Template
  2. Create an Enum Var
  3. Create a Macro
  4. Create an Enum Output
  5. Plug the created Enum var to Enum Output
  6. Bam, log error.

Here is a screenshot showing it;

Also if you drag the pointer of the variable to the Output and create the enum output that way, it pretends to work as it compiles, but reopening the template causes the error appear.

Here is another screenshot from my own project, showing the error once again;

I can share my project aswell if it’s needed. This was not happening at Preview and I hope it’s easy to fix before 4.10 is released. I just can’t revert back to Preview 3 :frowning:


Hi Achilleon,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?
  • I attempted the steps above, however they did not reproduce this error on my end. Are there any other steps I can attempt?
  • What is the enum type of both the variable and the output you are working with?

Hello Mr .

  • Yes.

  • Here is the video about how to produce it. You will see that it all works good and nice. But the moment you reopen the project, something breaks the pin codes of macro. Watch the video please, and you will see. =)


  • Enum Type is something I create myself. As far as I know the engine-self enums do not cause this. You will see that in the video too. Output is same with the variable, type that is.

Unfortunately I haven’t been able to reproduce this on my end. Can you send me a sample project I can take a look at that shows the error you are seeing?

Sure thing!


It’s just a 2 MB project so suit yourself Mr !

If you still dont see the bug I will flip a table! <.<

PS: Please note that this does not happen at 4.10 Preview 3. It only happens at Preview 4.

I was able to reproduce this on my end and have entered a bug report, UE-23066, to be assessed by the development staff. It appears that this error occurs primarily due to the enum get variable being located directly within the macro, as a workaround, try creating an input of type and plugging the get enum variable directly into the input within the event graph.

Thank you for the workaround Mr , but as I mentioned before, even if you do it, the next time you open the project you get the same error. Trust me I tried many ways! Anyway, I hope it gets resolved soon! Good luck!