Entry name 'META-INF/android.arch.lifecycle_extensions.version' collided while trying to package UE Oculus VR project

I’m new to UE dev. I’ve installed it recently, along with Android SDK and Android studio. I’ve followed the steps described in this video and this tut. I’ve created a dummy Oculus VR project and I’m trying to run it on my Oculus Quest 2. I’m getting this error during packaging:

ERROR: cmd.exe failed with args /c “C:\UEProjects\MyVRProject\Intermediate\Android\armv7\gradle\rungradle.bat” :app:assembleDebug.

I went into the folder and ran: “rungradle.bat :app:assembleDebug --stacktrace” and I got:

A failure occurred while executing com.android.build.gradle.internal.tasks.Workers$ActionFacade
Entry name ‘META-INF/android.arch.lifecycle_extensions.version’ collided

See the full stack trace herelink text. I tried different workarounds described in the net, but nothing worked.

Has anybody seen this?

1 Like

I have deleted the “Saved” and “Intermediate” folders and now it works …

this worked, thank you.

This was the perfect solution, thank you!

I was getting this error in Android Studio - what worked for me was the “Build → Clean Project” menu item in Android Studio. Deleting the “Saved” and “Intermediate” folders didn’t help in my case.

(My setup was, a UE 4.26.2 Debug Editor source build, Android Studio 4.1.2. Deleted “Saved” and “Intermediate”, launched the editor, packaged an Android ASTC build in the Debug configuration. Installed the build on my Quest via the .bat file. Opened the android studio project in Intermediate\Android\arm64\gradle. Tried to click the “Debug ‘App’” toolbar button)

1 Like

I had
Entry :META-INF/CERT.SF invalid offset
error message

This method also worked for me, please accept my knees.

very very thank :slight_smile:

In my project this happens regularly for unknown reason, but for me it’s enough to delete only the “Intermediate” folder and kep “Saved”. This way project packaging don’t take forever every time after doing this fix.

It works for me ,my setup was UE4.26.1 Debug Editor source bulid ,Android Studio 4.0.0.Deleted “Saved” and “Intermediate”, not work.