Enigine crashes at 97% upon loading Project

I get this error every time I try to launch my Project. I didn’t really change anything significant as far as I remember. Tried updating drivers - didn’t do anything. Have been working on this project for half a year and somehow thought a version control system would be overkill. If anyone can help me with this I’d really apreciate it.

This is the error code:

Assertion failed: UnscaledViewRect.Width() > 0 [File:D:/Build/++UE4/Sync/Engine/Source/Runtime/Engine/Private/SceneView.cpp] [Line: 718]

1 Like

Since 4.26 recently came out and you mentioned you’ve been working on it for a 6+ months have you tried using the previous version of the engine that you initially built the game on to ensure it can still load?

If this is a C++ project try building/running from Visual Studio as well instead of the Epic/UE launcher. Also try doing a clean build from Visual Studio if this is a C++ project.

Also additional information will be helpful in determining the issue(s):

  • What engine did you start building the game with?
  • What project type is this blueprints or C++?
  • Have you migrated your project to multiple versions of the engine? Ex: Started at 4.24, moved to 4.25 and now moving to 4.26?
  • Are you on Windows 10?

I’m on Windows 10 using the Blueprints version. Started out in 2.24, then 2.25, 2.26. I build the meshes in Blender and Character Creator, and used quite some Quixel Megascans assets. System specs are Ryzen 7 2700x, gtx 1080, 32gb ram. Although I didn’t quite hit 60fps in engine my system ran the project quite fine with realatively few crahes. I didn’t optimize the level for gaming since It was planned as a virtual production/cinematic type thing. Thx for the Answer

Try running the project within 4.25 and seeing if it’s able to load. You may need to wait for a hotfix release to address a specific bug affecting your use case.

Happy to help. Glad it was a simple fix!

Got it fixed already. Verified the 4.26 of UE4, thats it. Sorry I didn’t come up with this earlier and thanks for your help Winslow.

I had the same error happening to me since last week and the only work around I found was to create a new project and migrate everything there. That said, it has happened again.
I’m sorry but I don’t understand what you mean by “Verified the 4.26 of UE4, thats it.”. Could you explain how you got it fixed please?

For what it’s worth, I was able to track it down as far as the following:
I’m working on a Editor Utility Widget tool and after being loaded in the editor, then close it, then try to launch it again, it’s when it always crashes. But if I delete the Saved folder, then try to launch it again, it works. While in the editor, I have no issues whatsoever working with the Editor Utility Widget. It’s only after it’s loaded and then the editor is closed when the crash starts to happen at the next launch of the editor.

Blueprint project