Download

Engram still won't show up!

I’ve been trying to make a chaingun mod for quite a while now. It was actually the first mod I started. I’ve looked at as many things as I could, but both it and the ammo refuse to show up in the engram list. I’m going to upload the files in the hopes that someone will be able to help me.

Please help!
I’m not going to add any new models or animations until I get it working, so that’s why it’s barely different.

You do not have the testgamemode set to your mod in the world settings for your level. That’s why they do not show up.

world1.png

Also, you don’t need to specify a map under the PrimalGameData_BP entry anymore either. In fact if you have TheIsland specified, my understanding is that it won’t work on other maps.

14cc051a8ee799b5821e9dda4c72f4d53100f643.png

BTW, if you want to make them craftable in the fabricator, do this: (first untick “Give blueprint to player inventory” on each of your engram entries)

174c587631182fe38f2a723f6697b115f1b6fe9b.png

Then modify PrimalGameData_BP_Chaingun as such: Find “Additional structure engrams” and click the + once. Set it to “Storagebox_fabricator” in the section labeled “for class”. Click the + next to “Class additions” twice. Set those to your 2 items. IE: PrimalItem_WeaponChaingun & PrimalItemAmmo_ChaingunAmmo.

gamedatabp.png

Once you have that set, open up PrimalItem_WeaponChaingun & PrimalItemAmmo_ChaingunAmmo and look for “Crafting requires inventory component”. Click the plus 1 time. Select PrimalInventoryBP_Fabricator. Do that for the ammo and gun bp.

inventory.png

5775a8ab21bc8874d68f7019619012400c476a42.png

Save, cook, upload and start chain-gunning!

P.S. You will have to create a new fabricator for them to be craftable. They will not show up as BP’s in a pre-existing fabricator, only in ones made after adding the mod.

The GameMode is specified in the PrimalGameData - not the Level BP, and does not need to be specifically set in the override for them to appear on the Test map in the settings for that map.

To clarify a little, this means a fabricator in-game needs to be rebuilt to be updated with mod items.

EDIT: To the OP, creating a second thread around a day after the first is not an acceptable means of getting help. Stick to a thread per topic, and bump - within reason - if you still need assistance.

-WM

Thank you so much. If this doesn’t work i’m just going to give up. Really appreciate it!

Thanks for the tip. I’m still quite new to this but all I know is his mod would not show the engrams until I set the testgamemode override on his Chaingun level. Not the test map, his map. Once that was set, they were visible. Granted I did not test it before making that change. It was the first thing I noticed, only thing I changed and the first time I loaded the mod the engrams were there. So either it already works as is, or that change made it work.

FYI, You’ve got other issues with this. I was confirming that above steps make it work with the fabricator so I could upload it for you and it does mostly, you can craft the gun and the ammo however the gun does not appear in your hands. Im guessing whatever skin you’re using on it is not loading correctly and I don’t know enough yet to help you with that one. :frowning:
But anyway, here is a working (for the most part) version of your mod. The only things I changed are what I went over above.

Thanks. I’ll look into the thing with it in your hands.

I had to check the "allow equipping"box. That should fix it. Everything you did helped! Thanks!

The GameMode does need to be set, but as I stated, this should be done in the PrimalGameData BP.

-WM