Engines no longer recognized

It looks like maybe verification has failed, somehow.click the down arrows and click verify, ONE AT A TIME. It takes some time but may prevent engines needing reinstall.

Have you tried logging out of the launcher and back in?

This issue relates to UE4.22 through to UE4.27 and UE5.

Yesterday while the log in issue was happening, I was able to get into my account. When I got in, my installed engines were all greyed out and said ‘install’ - despite the UE4Editor.exe being in the correct folder (no I did not move them).

Please note in the image above 4.27 is not yet installed. I tried re-installing 4.26, which is when I discovered my engines were still installed.

When i tried to open a project, it would say no installed engines detected did I manually want to the engine. Clicking this would result in nothing happening.

I had an idea this morning. By Installing 4.27 I was able to open projects and in the correct engines (I tested it with a 4.26 and a 5.0 project). However, neither engine became ungreyed and resulted in the project being listed as ‘other’.

The projects open fine and run in the correct editor, besides the above issue.

Now, mid-afternoon here, and 4.27 (which I have done nothing with) is also greyed out… as shown in the last screen shot below.
I am afraid to delete the UE4 engine files and re-install an engine at this stage due to the glitches I am experiencing. I am not sure where to start with this, as everything I could find so far is if someone moved their install folders.

Any advice/ideas/suggestions?

Sadly, the verify option is greyed out too. The only options I can click are ‘set as current’ and ‘remove’.

Yes. Multiple times. One of those times is when 27 went bad.

After 3 full re-installs I found the solution…

  1. Uninstalled the launcher
  2. Using window’s tools uninstalled all games that were listed
  3. Manually deleted the programdata (C:/) and the engine and game folders
  4. reinstalled the launcher (found an error where it still thought the engines and games existed)
  5. uninstalled the launcher
  6. Reinstalled the launcher
  7. Reinstalled all engines and games.