Engine won't start - Nvidia problem?

Please help – not been able to do any development for 3 weeks.

I have been happily using an Acer Predator laptop for development for over a year. I had the Windows 10 April 2018 update a few weeks ago. Instantly I was unable to use Unreal 4 without suffering issues with very dark colours. Also impacted my game of choice: World of Warcraft which wouldn’t start at all! Rolling back the update sorted all the problems but obviously this is in no way a solution.

With the help of a friend and some research the problem appears to be a Nvidia driver and Unreal conflict. I have taken the following steps to try and resolve the problem:
• Uninstalled and reinstalled the Epic Launcher and Unreal 4.20 – had to use the Microsoft uninstall tidy-up utility: Fix problems that block programs from being installed or removed
• Uninstalled and reinstalled the latest Nvidia driver – GeForce GTX 970M – using DDU
• The Nvidia control panel on the laptop has limited options

Now the launcher is fine but Unreal Engine will not start at all. Instead it launches the crash reporter which then crashes itself so it cannot even be viewed. (WoW now works though!)

So I am stuck. I do not want to restore to the previous version of Windows 10 again as this sort of problem will simply recur at some point.

I am sure I am not the only laptop user that has had this problem. Please help!!!


I have the exact same problem also with an Acer Predator laptop and a Geforce GTX 980m with an added bonus of the launcher also being broken now. What I did see however is that the launcher is open and all the links work but nothing is rendered.

Anxiously waiting for a superhero to find an answer because I am so tired of following guides that do not work :(.

I found a solution to my crash. All I had to do is make a shortcut to the Unreal engine on my desktop, in the shortcut’s properties, at the target field, I added a space followed by -DX12 (This is case sensitive).

Unfortunately, this is not a perfect solution and seems to not work for everyone. It does make the editor work if you use a shortcut from the Desktop but the same problem still occurs when you launch the game form the Epic Launcher. Another problem that still exists is the moment you try to debug your code from Visual Studio the engine goes nuts.

Since then I formatted my Laptop with a clean install of Windows which fixed all my problems. I do realize this will not be possible for everyone though.

same problem here with acer predator

Is this a problem specifically with Acer Predator laptops. I have an Acer Predator G9-591 with an i7-6700HQ, 32gb ram, gtx 980m and am experiencing the same problem after the season 7 update of Fortnite, a Windows 10 update and the Nvidia driver update v.417.22. I have tried everything from uninstalling both Fortnite, Epic games, Unreal engine to reverting to previous drivers and versions of windows. I attempted the solution PsychoSTS proposed and still no difference.

If anyone can knows of a solution I would greatly appreciate if you could share. I will continue to search or a solution. Should I find one, I will return with the solution to this thread.

Hi Carlos, the solution I proposed semi-worked for me, and in the end, it just postponed the problem. I tried everything that was proposed online and everything that you also tried… Nothing worked.

Since then I completely stopped working on my project and with Unreal Engine since I could literally not develop my game.

I installed Unreal Engine again now quickly and everything worked perfectly. The only big change is that I formatted my Laptop completely with a fresh install of Windows and all my drivers. I know this is not necessarily possible for everyone hence why I just wrote a comment if you wanted to try it.

I will also change my answer to not confuse someone else that comes across this thread.

Thanks. I kinda got around it by postponing the April 2018 Windows update. Then it caught me napping and went ahead, Seems fine now…