Engine Texture error

Hi everyone,

I keep getting an error on engine textures that I am not even using in my paper2d project.

I fixed all my textures to a power of 2 and set their Mip Gen Settings to NoMipMaps winch in turn removed all my custom texture errors from the log but I now have engine texture errors.
Perhaps I did not setup something in the project settings correctly.

I have a bunch of errors like the following and they are all engine assets:
LogTexture: Error: Loading non-streamed mips from an external bulk file. This is not desireable. File …/…/…/Engine/Content/EngineMaterials/T_Default_Material_Grid_N.ubulk

I’m not using any materials or particle systems, only paper2D sprites.

Reading up on Mobile Texture Guidelines I don’t quite understand how to setup the compression settings.

{ It is recommended that you only use TC_Default or TC_NormalMap in the Compression Settings as any other setting could cause your Texture to take up more memory than expected on your target device. }

Does this means I need to use Default (DXT1/5,BC1/3 on DX11) or NormalMap (DXT5,DC5 on DX11) ?
As TC_Default and TC_NormalMap do not seem to be an option.

The errors only manifest when I test the game on my android phone and then quit. Also if I try to launch in the mobile preview PIE, the game doesn’t run as expected.

I’ve been trying to fix this for the past week, reading up on mobile guidelines and looking at similar topics here in the forum but getting nowhere really.

Thank you in advance.

Seems like this errors are present in UE4 templates as well so I guess they can be ignored if the game works fine.

I have no idea whats going on with UE and mobile textures.
The documents seem to give little to no advice.
I cant find much else on them. And I’m a complete noob with about 4 months experience.

I’ve spent days working on mine trying remove errors, to be warned of another error, to have the engine just randomly change something itself and then I have to change it back.
And every little tweak results in 10+minutes of compiling shaders.
I have my landscape down to 4 textures and yet on shader preview it’s super red…i just dont know

so i feel your pain. I feel your pain