Download

Engine Not Compiling

Hey Everyone,

For some reason I can’t get the engine to compile for me… This is the error I get.

I have also switched it from DebugGame to DevelopmentEditor but still the same error.

Thanks
Kevin

Which version are you trying to build? Did you upgrade/switch to a new branch recently? Try deleting the Intermediate folder, regenerating the VS files and rebuilding.

Did you change any header files recently? UnrealHeaderTool scans all the headers to build the reflection data. According the report, it failed in UE4Editor so start there.

Nope no changes to the editor, just downloaded the 4.2 files fresh, extracted and tried to compile.

The error message comes from the UnrealBuildTool. Look in ExternalExecution.cs for it. I’m not sure why, I didn’t dig deeper.

Also check that you have enough free disk space, UE4 requires a LOT of free disk space to build.

If that fails, try using git clone to get a fresh copy. I did that and it compiled fine.

Make sure you have June 2010 DirectX runtime installed.