Engine killing audio on zero volume

Hello there!

As title suggest, I’m pretty annoyed, that Engine seems to kill/pause sounds when volume is set to zero. I need to find where it happens in code so i can turn it off. I’ve tried to do some workarounds but without success :confused:

Anyone here can help me with that? I’ve tried to find it on my own, but haven’t seen anything like that.

My engine version is 4.15

Yeah this is a thing. There’s no project-wide setting for this that I know if, but you can open the sound asset and check ‘Virtualize When Silent’ - which will force a sound to simulate playback even when volume is silent.

Be careful with it though.


I currently need to use sound virtualization on almost everything to avoid huge audio delays when navigation is rebuilding.

Could you elaborate the need to be careful? What problems might arise with it. Thanks.

Because virtualizing a sound means you are still using up a voice/channel even if it’s not audible.

1 Like