Engine Freeze / Horrible FPS GSync/F.lux

(As if my Epic Launcher freezes were not annoying enough)

This isn’t just 4.13 sadly. But it is the latest I am using, but this happens in 4.12.5, 4.11.2, and 4.10.4.

I open up a blank project and I can’t get past 24FPS sometimes (it’s almost random, but it’s been happening a lot more lately). I originally thought this was an OBS issue, and there ARE some issues with Desktop Capture, but I am not using OBS when I open up a project usually and I still get this. What’s crazy is SOMETIMES, it works and I get 120FPS (my current default refresh rate). I have a triple monitor setup (3x Rogswifts). GSync is usually on. So is f.lux.

I had originally thought this was an issue with f.lux but I just noticed disabling and enabling GSync is causing the freezes also. So now with f.lux on and then I disable it… it usually either a) causes a crash in the engine or b) does nothing to help the fps issue.

BUT When I disable or enable GSync via the Nvidia Control Panel, it usually causes the engine to freeze up, however, when I start the project back up, and it’s disabled I get 120FPS.

Steps to reproduce after my little sob story:

-I Just reenabled f.lux with GSync still off and I get 120FPS. Exited.

-I Just reenabled GSync on with the Windowed and Full-Screen settings. 24FPS or less.

  • Switched to Full-screen mode only GSync (which, should mean nothing for the editor), f.lux still on. 120 FPS

Conclusion: GSync Windowed + UE4 = Bad Idea. F.lux has nothing to do with the FPS issues, but did cause engine freeze when disabled. So, if I make changes, close editor out first before doing so.

The reason I probably didn’t catch this before is that I had GSync on Full-screen only by default. Well. Now we know. Hopefully this helps out someone else in the future.

Hi VictorBurgos,

  • Are you running an SLI setup on your multiple monitors?
  • Can you post your dxdiag here so I can take a look?
  • Is the editor on your primary or one of your secondary monitors?
  • Is the FPS drop immediate or do you take any actions before this occurs?
  • Does the framerate drop only when you have OBS or another stream software open or does it happen even when these programs are not in use?

Hey ,

  • No SLI
  • Dxdiag posted
  • Editor on my primary monitor
  • FPS drop is immediate
  • The framerate drop seems to happen most regularly when I activate windowed GSync mode instead of just GSync Fullscreen only.
  • Freezes occur whenever I do change GSync settings, as well as f.lux while the editor is open. link text

Hey VictorBurgos,

I just wanted to do a quick update to let you know we’re still looking into this. I’ll post back here once I have more information available.

No biggie . Just knowing I can’t use G-SYNC Windowed on UE4 kind of sucks, but I suppose it’s not truly needed for game dev, and knowing that setting it to full-screen or off allows me to get my max framerate, is just fine for now.

For me the performance drops happens as soon as i drag a editor window onto the G-Sync monitor, every window on the g-sync monitor (e.g. a Blueprint Editor) has about 10FPS for me, while the windows on other screens (without G-Sync) reach the editor max fps of 120 FPS. Dragging the slow performing window onto another screen makes it run fast again and vice versa.

Using 4.12.5

Glad I’m not the only one :slight_smile: Yeah, it’s definitely a G-Sync <-> UE4 issue. You can get rid of it by placing GSYNC in Full-screen mode only, so the editor won’t get picked up.

1 Like

I’ve also noticed this is only caused, while the game window is focused. When tabbing out the games runs fine…
Running in Fullscreen gives me about 160-300fps in my game, which is the expected performance on my GTX 1080.

Hi everyone,

This is an update like the one before. We are waiting for some equipment that is currently indisposed to be able to test on.

This seems to be a general G-Sync problem, not related to the Unreal Engine: https://www.reddit.com/r/nvidia/comments/3fbn0i/low_fps_20_fps_in_windowed_high_fps_144_fps_in/

This is not a general G-Sync problem. The only application with this problem (for me) is the UE Editor.

This isn’t new either but I gave searching another try today and this is fairly recent.

Info that might or might not help:

The UE Editor seems to be rendering in a weird way.

The FrameRate display from the nvidia driver seems to appear in multiple places, sometimes even simultaniously:

  • Tab-selection of the window (not blueprint graphs), any tab, sometimes multiple at once
  • Right-click menu
  • Top right of the main window.

For some reason the number is always everywhere the same when it appears in multiple places at once.
The framerate climbs ridiculously high when displayed in many places.
This kind of looks like the framerate of every rendered piece is added up.

Hence, my own conclusion is that somehow gsync tries to sync for every rendered area so you get Monitor-FPS/Rendered-Areas = True-Fps.

Also, with V-Sync enabled on my 60hz monitor the nvidia fps overlay displays a whopping 120 in a blank project with no extra tabs open and exactly 240 when a right-click-menu was opened. This kinda supports my hypothesis that multiple screen updates happen per rendered frame - which can be exceptionally bad for gsync.

Ok, so further research into the settings and setup of things has removed the problem for me. Can someone confirm this for me? It might just randomly be working again.

Go to nvidia control panel. Change the 3D-Options for the engine. Forcefully disable V-Sync. For some reason the engine was listed twice and I had to remove it on both instances for it to work.

Also, I previously checked that V-Sync was disable in the editor. It seems like the editor setting does not work and the editor still uses V-Sync.

In case you are new to G-Sync: V-Sync and G-Sync are a perfect combo if you are not gaming. Maximum amount of visible frames and no performance lost. Saves performance => energy => money.
Sadly it doesn’t seem work with the way the engine renders.

Because the engine renders multiple viewports its just more likely to occur, I’ve had the same problems rarely in e.g. Overwatch.

Heh, I just disabled G-SYNC windowed mode, it doesn’t help me in the engine so…wasn’t missing out on anything. I just noticed how long I’ve had it disabled for…it kind of sucks, since I obviously paid a premium for these monitors ( I have 3x Rogswifts) and can’t use G-Sync properly (in windowed mode anyway) for gamedev.

YES, disabling Vsync in NVIDIA control panel fixed my mouse lag! Thank you so much. I tried the Enable G-SYNC for full screen mode setting and was still getting this issue. I had tried so many different things in the past hour trying to diagnose the issue to no avail until I came across this post.

To further detail what I observed with this same issue, I just got an Alienware 240Hz 1920x1080 display. This evening, I noticed some mouse lag, actually only occurring within Unreal Editor and more specifically the Blueprint editor when it had focus. I could let the mouse sit idle for a few moments and when I’d start to move my mouse, the screen would very, very slightly alter brightness and the mouse would be lagging during this moment. If you continue to move the mouse, the mouse will become silky smooth as expected with high refresh rate. If you leave the mouse alone, moving the mouse once again will reproduce the symptom. This issue only occurred on my high refresh rate monitor that was using NVIDIA G-SYNC. If you turn off G-SYNC, the issue does go away, but was hopeful that there was another way to leave it on. When I disabled V-Sync this thankfully went away. Thanks again!

If you are hitting the max editor fps with gsync off, you don’t need Gsync. Its advisable to turn it off regardless in windowed applications