Engine download ends with waiting message

I ve installed launcher, clicked on install engine, accepted licence and it nothing happens, download does not start. Only message waiting. I ve tried to turn firewall off, tried to install launcher in default folder, also run launcher under admin rights. I am not behind proxy. I ve tried recommended steps from other similar topics, nothing helped. Log is in attachement.

It appears your link to the other topic didn’t link properly. I apologize if you have already tried this, but would you be able to give these steps a try?

  1. Uninstall the Epic Games Launcher.
  2. Re-download the Epic Games Launcher.
  3. Right click on the installer (before installing) and select properties.
  4. Within the General tab select ‘Unblock’ and Apply.
  5. Turn off UAC (User Account Control)
  6. Install the Epic Games Launcher.
  7. Restart your machine.
  8. Download the Engine.
  9. Re-Enable UAC if needed.

If these steps still fail you can try resetting your winsock catalog back to a clean state and your TCP/IP settings. That can be done with the following commands from a command prompt.

netsh winsock reset catalog
netsh int ip reset reset.log hit

Had the same issue, just uninstalling, redownloading and installing the launcher fixed it for me.

Thanks, this really helped! I wish old times with simple downloading of installation binaries are back. These launchers are pain :frowning:

Hi everyone,

For anyone else having this issue. Give the workaround posted here a try. Let us know how it goes.