Engine crashes when loading project that worked fine before

I was working on my project last night. Everything worked well, I saved it all, quit UE4 and turned off PC.

Today after work I wanted to continue working on it, so when I tried opening the same project it would crash the engine. Here is the crash report:

Why is this happening ? Is there any way to make it load properly ?

I can provide my project to Epic staff via PM on UE4 forums, if necessary.

have you tried deleting Intermediate? perhaps recalling a older version of this blueprint from your Saved\Autosaves might help

be-careful and save backups - I’ve lost a few blueprints to issues like this, it sucks - worst case scenario just delete the actual blueprint then load your project, you will have a ton of errors because the BP is missing and will have to do a lot of work to get it to run again, if you are using source control you might be able to wedge back in a working version of that bp

I think I found the issue. I have Child Actor component in FirstPersonCharacter and in that Child Actor component (another BP actor) I have cast to FirstPersonCharacter node with player pawn input. The cast node doesn’t have any execution, but I guess engine still tries to execute it or something.

I fixed it by opening crosshair BP in a blank project, deleting cast node, saving it and replacing original .uasset in my project with the one I just modified. I had to fix BP all over after that, but it works now.

good idea, ill try that again if I every run into this again - I havn’t had this problem since the earlier days of UMG tho