Engine crashes when I drag a pin

I have a class called controller, it is the main player class to the game.
After updating, whenever I drag a pin from the node, the engine crashes. It only occurs with this class.
I’ve tried renaming the class, and using another reference type variable, but nothing happened. It only crashes with this one class.

I have messed around a bit, and I have found that the engine only crashes with my pawn has functions with a delegate paramater. Inside the function, I unbind all events from an event, and bind the event that was passed in.

This glitch also occurs in 13.2, and is now happening to a class that has no delegate parameters. Functions that have a delegate parameter can be used within its owning class, so long as its copy and pasted. Any other means of creating it will crash the game.

Hi Willard720,

Are you able to reproduce this in a new project or is it only occurring in your project that was converted from a previous engine version?

Some screenshots showing exactly what you are dragging off of, the functions with delegate parameters, and inside the functions themselves could be helpful in reproducing this.


This function exists in the class I named ‘control.’ This is the player’s controller, and it was named ‘controller’, but I changed it thinking it was the name that was causing the problem.

This is one of the two functions that are used for an external class, ‘turn manager’, to bind events to the player’s controller, specifically the ‘accept’ button.

This is from inside the control class. New Var 1 is a control class, and after dragging it out like so, the engine crashes. ‘Get Controller’ is from a global library that returns the control class. Dragging off a pin from one of them will crash the engine as well.

This function is outside the control class. I created it to bind the event using one node, instead of two.

So long as you have copy & pasted, or duplicated them.

Then the engine crashes.

The first two screenshots were hard to take because they were on the 14.0 version, which crashes within 5 - 10 seconds without anything happening. The rest were in 13.2, where I found later that these same bugs exist, so they are not new from 14.0

Also, now dragging from my player class in 13.2, which has no functions that use delegate parameters, is causing the engine to crash as well.

I’ve tried a lot of things to fix this. I duplicated my player and controller crashes, but that didn’t work. I migrated everything into a new project, but it still crashed.

I found out it had to do with the Turn Manager class. In here, it crashed even if a pulled a pin from a new bool. I duplicated the class, then it worked, for a while, before crashing when I drew the player pin. This class still has functions with delegate pins, so I will try to move those.

These crashes only happen on the reopening of the program. When I placed a new variable and dragged out a pin, it would work. But when I close and reopen, dragging a pin from the same variable would then crash the engine.

I haven’t been able to reproduce this crash. Could you also provide your Epic ID/Machine ID from the crash? As well as the callstack and crash logs.

Hi Willard720,

We haven’t heard back from you in a few days, so we are marking this post as resolved for tracking purposes. If you’re still experiencing this issue, please feel free to post back here with additional information to reopen the post.