Engine crashes when AI spawns

hey guys, I have a pretty strange problem, I have a basic ai that follows the player, up until recently all was fine, now whenever the ai is spawned into or present in the game the entire engine crashes.
weirder still is that if I go into the behavior tree and disconnect all the nodes from the graph save compile and run i will not get a crash, the ai will instead run pretty much as normal, even though the tree says only the route node is firing. After running the disconnected behavior tree I can then go back and reconnect all of the nodes, save and recompile, the ai will work perfectly with no crash. This will only last until I close the engine, if the engine is closed and reopened the process has to be repeated.

im running version 4.5.1 below is the crash report im getting


Access violation - code c0000005 (first/second not available)

UE4Editor_CoreUObject + 1416365 bytes
UE4Editor_AIModule + 532555 bytes
UE4Editor_AIModule + 537241 bytes
UE4Editor_AIModule + 1140804 bytes
UE4Editor_AIModule + 1138763 bytes
UE4Editor_AIModule + 1135862 bytes
UE4Editor_AIModule + 609634 bytes
UE4Editor_AIModule + 962005 bytes
UE4Editor_Engine + 8808057 bytes
UE4Editor_Engine + 9013865 bytes
UE4Editor_Engine + 5620079 bytes
UE4Editor_UnrealEd + 1895346 bytes
UE4Editor_UnrealEd + 6486374 bytes
UE4Editor!FEngineLoop::Tick() + 3524 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\launchengineloop.cpp:2129]
UE4Editor!GuardedMain() + 479 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\launch.cpp:133]
UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\windows\launchwindows.cpp:125]
UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\windows\launchwindows.cpp:201]
UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

Hi ,

There are a couple of things that could be the cause, but in order to better assess the crash, I will need the log file. Can you please attach the crash log file from your [Project]/Saved/Logs folder? That will have more information about what happened to cause the crash.

Can you tell me of any specific changes that were made leading up to the crashes? Any new custom tasks, services or decorators?

Also, since this occurs on an older build, have you tried it on 4.7.6?

Any additional information may help as well.


Hello again. In order to continue with the investigation, I will need the information requested previously. I’ve moved my previous comment into an answer for now, but please post to reopen the thread and I will be happy to further assist.

I am having this issue in 5.2. Spawning my AI causes the game to crash with the same error above – mentioning AIModule etc…

Anybody got an idea what is going on? I am creating level instances and using child actor components if that’s relevant… I suspect they have something to do with it.