Engine crashes on save/delete anything/play/compile blueprint

The engine crashes whenever I save, save a specific blueprint. It crashes when I try to delete anything, if I play it crashes on any of the options. If I try to compile a blueprint it crashes. It only occurs on my project and not on a new one. It worked last time before I closed the editor down.

link text the crash log and minidump, if you need the project just say so.

Maybe your PC is junk? IDK maybe u are using to many system resources in the background. Try only having UE4 up at one time, maybe your save file is in a full drive. Hope this helps.

So I actually found the answer thanks to the output log.

“LogBlueprint:Error: [compiler Base_House] Error The current value (/Game/Buildings/Resources/Marketplace.Marketplace_C) of the ’ Collector Type ’ pin is invalid: /Game/Buildings/Resources/Marketplace.Marketplace_C isn’t a valid subclass of Base_Collectors_C (specified on pin Collector Type)”

Which I thought was strange seeing as the Marketplace_C is a subclass of Base_Collectors_C, so I went ahead and changed the value to nothing and saved before I compiled. When I hit compile the same error came up and the editor crashed, I figured that the Marketplace_C wasn’t the issue in the first place. Upon restarting the editor I noticed I could suddenly compile without the engine crashing, I went back and changed the value back from nothing to Marketplace_C again and saved and tried compiling and restarted the editor. Lo and behold I couldn’t compile again.

Since nothing of value was lost as Marketplace_C was just a data blueprint with nothing changed I’m gonna marked it as solved. But I’m still curious why it has worked for so long until last night when it suddenly stopped when nothing has changed.