Engine crashes after building navigation

I am having an issue where the navigation becomes invalid after either running a simulation, or opening a blueprint. When I try to build to rebuild the navmesh, the editor crashes.

Here are the log/dump files in case that helps.
Both uploaded files were renamed .txt so they could be uploaded.

Log file

Dump file

Thanks for reporting it. I’ll have a look as soon as possible. In the mean time it would be awesome if you tried reproing the issue with latest 4.7 preview build - it’s quite possible the bug has already been addressed.



Cloned the project and upgraded to 4.7 preview 4 and the issue is still happening. It also seems to be after building anything else as well, so it may not be the navmesh building causing the crash.

Is there a chance to get our hands on your project, or a stripped-down version of it (as long as it’s crashing)? That would be most helpful.

Hmm. I seemed to have fixed it by opening a bunch of the ai related blueprints and resaving them. I did add a node to the behavior tree and a few tweaks to a task, and now it doesn’t seem to happen.

If it happens again I can upload a copy of the project.

Having this happen again. I have uploaded a zip of the project to debug. http://1drv.ms/1z2WTtI

Hi csharp1024,

I was easily able to reproduce your crash with the project you provided. I created JIRA UE-8906 in our tracking software and our devs will be investigating the issue.

We’ll post back here as soon as we have an update.