Enabling RVO Avoidance after a collision

In the game I’m working on we have some characters moving around the map and of course sometimes they run into each other. I have it set up so that if the character that gets run into isn’t currently doing anything it just moves out of the way. If it is doing something (moving, attacking, etc) then I turn on RVOAvoidance for the units but that doesn’t seem to do anything, they just keep moving straight forward as if I didn’t turn avoidance on at all. If I just leave avoidance on all the time it works, but it’s not the behavior I’m looking for. Any ideas what I’m doing wrong or things I could try to get this working?