Download

Enabling root motion resizes model during animation. HELP!!

Summary:
I’ve been trying to find information online, but I can’t seem to find anyone else who’s run into this problem.

I have animation assets purchased from a pack in the Unreal Marketplace. I’m trying to retarget those animations to another custom rig I purchased elsewhere. The skeletons are a different size, but I thought I had my settings correct to correctly translate and retarget the animations.

When I don’t enable root motion, the model stays the same size. But of course, the capsule doesn’t follow the animation.

But when I enable root motion in the animation settings, when the animation plays, the character model size decreases. And I’m pulling my hair out trying to figure out why. I’m completely at my wit’s end. See GIF:

What I’ve Tried:

  • **I made sure my retargeting settings were correct. **Per my knowledge, the root and pelvis are supposed to be set to “AnimationScaled”, and the rest of the bones set to “Skeleton.” Is this correct?
  • **I tried other retargeting settings. **I’ve tried just “Animation” on root and pelvis. Same thing. I’ve tried “AnimationScaled” everywhere. Same thing. “Skeleton” on everything doesn’t even look right.
  • **I enlarged the source skeletal mesh to be the same size as the target skeletal mesh, saved the new retarget pose, then retargeted the animation. **Still saw animation resize
  • **I shrunk the target skeletal mesh to be the same size as the source skeletal mesh, saved the new retarget pose, then retargeted the animation. **That didn’t fix it either.

Let me know what other information you need to help. I might be missing something completely obvious and stupid because I don’t have a background in animation or art, so I’m sort of feeling my way through this :slight_smile:

export to Blender and address it there.
it could even just go away without doing anything since the animation in blender is handled differently when it comes to root.

Unfortunately, that didn’t work. I imported into Blender and re-keyed every animation frame to adjust the scale and then re-imported it. It still resizes as soon as I check Root Motion. I have no idea what the cause of this is.

I know that it’s just a scaling issue, but I thought that having my retargeting to “AnimationScaled” would address this, and it’s not.

Well that’s because the option is unrelated to the actual scale. it deals with how bone motion is interpreted.

What is the correct size? With root motion or without?

In blender root motion is the model iteself. so if you apply all transforms you should always get a 1:1 result unless you go and purposely scale the armature yourself.

IF you have default bones setup, you may just want to try parsing the whole thing through my blender addon:
http://mosthostla.com/gamedev/bonebreaker/
If you have extra bones that probably won’t be possible at this time.

Update: It’s working now. For anyone else coming across this thread, I messed around with the settings in the animation. See attached photo. Again, make sure your skeleton has the right retarget settings before you retarget the animation (root/pelvis on AnimationScaled, everything else to Skeleton). Then when enabling root motion, check these settings:

Annotation 2020-08-04 221911.png