Download

Enable World Partition checkbox is greyed out

There seems to be a couple people who are unable to enable World Partition in the World Settings panel even though we can enable it in the Project Settings.

Has anyone else encountered this and managed to fix it?

Thanks.

2 Likes

I had the same issue. What worked for me was creating a new level in UE5 -AFTER- I had turned on World Partitioning in the project settings. The starter content maps didn’t work for me and didn’t give me the option of turning world partitioning on even if it was on in the project settings. Maybe that setting isn’t retroactively available after level creation?

2 Likes

This worked for me, thanks.

You need to use the World Partition Convert commandlet. The steps are shown here:

1 Like

I’ve started on a blank map and the option was available, also if you close our map and open it again ue5 will give you the option to convert your map into world partition

@ZionChris I try command but Isnt work have you better example then from docs?

That’s for existing landscapes though, not for starting new ones. Starting a new level after enabling it in Project Settings works.

That worked. Thanks! Now to figure out how import a couple hundred height map tiles instead of just one.

@Durghan need convert exist landscape.

But that’s the thing, there isn’t an existing landscape. Nothing has been done yet. I load Unreal. Make a new project. And that’s it. No new landscape or anything yet.

@Durghan I have old project with terrain and actors and I want enable worl partitions for this level. Checkbox is gray unactive and commandlet has error

Got the same error using the commandlet, ConvertToPartitionedLevel Bad parameters

Want to convert my existing world composition world (with 200sublevels) to world partition

I have exactly the same error while trying to convert an old existing project.
I enabled in the project settings. it’s greyed in world setting and I get the same result when trying the converttopartitionworld command.