Download

Enable physics just drops?

I set an actor to be thrown and works ok until I apply “simulate physics” then just drops to the ground. I tried altering the mass scale / kg / and initial velocity, but no affect ?

Hi Espr3ss0, when you say you ‘set an actor to be thrown’ what do you mean? Is this with a physics handle component or just a ‘add impulse/force’ set-up?

Spawned with just vector direction & initial velocity, with projectile movement.

Hi Espr3ss0,

From what I can recall when I was playing with projectile movement, you can not simulate physics with projectiles.
I have just threw together a quick test and if I set the velocity and initial speed in the details pane of the ProjectileMovement component with the simulate physics off on both my collision component and sphere the ball will spawn with an initial velocity.
When I turn simulate physics on, my projectile does exactly what you describe, it just falls to the ground.

My way of getting around this originally was to detect when my projectile hit another object, then spawn a new blueprint class which was the same ball but without the ProjectileMovement component and it had simulate physics on. Then it is just a case of setting the linear velocity of the new physics ball to the final velocity of the projectile ball, which i stored using a vector variable.

Not sure if the above will help at all as it is more of a work-around. There may be a more convenient way to execute this but this was just one method that I had used.

Thanks for the suggestion. I have found that the projectile interacts with objects that have physics even though the projectile doesn’t, however this doesn’t work with the ground as setting it to have physics will of course make the floor fall like everything else.

Sorry about this post bump but I feel I should add it …

The order I put my collision & mesh, is mesh with no collision nested under the collision with block all. The projectile movement wherever but the important thing was dragging the collision onto the scene component which for some reason makes the scene component disappear I suppose is another question but the important thing is this is what gets it working to collide with static meshes leaving out the projectile’s physics.

Ok here comes my solution, but i am Blueprintamateur, but for me it works well.
Create this thing under settings / object channels.
9f9c6018dbca16ad86d8e290df45c31cd4819488.jpeg
Choose created class projectile use similar options(test out), but(big one), when you use overlapping events in any way in those collision process, generate overlapping events has to be activated on both actors of collision.
When you have placed many assets in the level and want to change behavior for all, it works only for ungrouped objects(massselection).