"Enable physics interaction" can't be disabled

The physics engine looks fantastic when it works, but I have been running into some issues.

My character causes physics bodies to be launched at high speeds, when he shouldn’t be able to move them at all. My character’s “Enable physics interaction” is disabled, but it still interacts in an unacceptable way. Note that the editor’s “run dedicated server” is enabled. I am not using CCD.

I have included a video demonstration, including my configuration.

Hey mgumley,

I have a couple of questions:

  • Does this still occur if the Run Dedicated Server option is disabled?
  • Does this occur with any physics object in your project or just that particular wall?

Hi Sean, thank you for the reply.

It is not as extreme in single player mode, but disabling “Enable physics interaction” is still broken.

It occurs with all physics objects.

At this point I’m forced to not use the physics engine because players can just push things around ( that they really shouldnt be able to move).

Hey mgumley,

I’ve reproduced the issue using the Run Dedicated Server option and have entered a bug report:

Thanks for your report.

Have a great day

Thanks Sean :smiley:

What does “won’t fix” mean?

The developers have decided that this is not a bug, with the reasoning being that no force is actually being applied to the object and the issue that we were seeing could have been do to collision pinging off of the object and causing it to be launched.