Download

Enable physics in cinematic animation playback

Hi everybody, I have a character with ponytail physical asset (see link #1 https://i.gyazo.com/02133c009488e22632f5a144b1557a62.mp4), animation and physic works fine in preview or playback, but when I use the animation clip in Sequencer the physics doesn’t apply (no swinging physics on the ponytail). When I try to enable physics in Sequencer, the animation clip doesn’t playback (see link #2 https://i.gyazo.com/f5500a8523998ee9…79746c6393.mp4). Anyone know where I did it wrong? Thank you!

Okay I figured out how to enable physic simulation in sequencer in case anyone has the same problem. Before sequencer playback, run the PIE in Simulation mode (Alt+S), then proceed to playback the sequencer. Next problem is if you want to record the sequencer to movie, it will force you to exit the PIE first, which will eventually turn off physic simulation. I will update when I work around this.

Ever figure this out?