Enable physics for specific bones

How can we specify specific bones to have physics enabled?
or to exclude specific bones from being enabled?

All Bodies Below Simulate Physics doesn’t seem to support this and I can’t find any other relevant nodes.

Its set it in the physics asset, in “body mode” set the bone to physics type,

Kinnetic - follows the animation not physics
Simulated - Physics
Default - does what its parent did

W Jones

Is it possible to do this at runtime though?

looks like we need set bone physics type to simulated at runtime

I’m not aware of a built in blueprint method, but if you’re using C++ you would do it like so.

MyMesh->GetBodyInstance(NameOfTheBone)->SetInstanceSimulatePhysics(bPhysicsOnOrOff);

GetBodyInstance() returns a pointer, so maybe also check that it exists and that the body instance is valid before calling the simulate method.

Thanks, setting in the Physics Assets enabled me to do what I needed.

Is there an update for this answer for the new Phat tool? I can’t find a Body Mode in the new tool. TIA