Download

Enable Non-root translation animation

I have a slime ball that when it attacks I translate an “arm” bone forward quickly. But that animation is not coming into unreal. I can’t find anything about enabling translation animation thats not root transform. Its not the root that transforms, I’ve also enabled that but it doesn’t seem to help.

How can I get my “arm” transform animation into unreal?

Root translates the actor and is driven by the animation, normal draws the pretty animations and relies on programming logic to translate the actual object. Root motion animations need to be set up as such; normal animations are set up to animate in place, root animations are set up so the animation actually moves off the spot. There are some great illustrations online.

Do you want to play an animation (the visual component) or do you actually want to change the some state of your game when the animation plays? These are related but different things.

Thanks for the response. I’m familiar with what root animation is for and does, it was just a step testing what might enable transform animation. I have a odd character. A joint has translate, rotate and scale. All animatable. I have a joint within the hierarchy that has something other than rotate animation, it has transform animation. That doesn’t seem to be enabled when in Unreal. Is there a way to enable this or no? If I had a sci-fy gun reload animation I imagine there might be a lot of sliding moving parts that are all transform animation. How does one enable this? Unreal3 had a checkbox that said enable transform animation (or something like that) UE4 doesn’t have that check box as far as I can find.

Hmm, don’t know off the top of my head (never come up for me lol, in my mind I rotate the parent bone to translate the child bone as they are all joined). That said you can manipulate the bones through blueprint - there’s a transform bone node for the animGraph that accommodates transform, rotate and scale. It’s a hack but if you only have one odd skeleton it might be a workable one until you find the ‘proper’ solution?

https://docs.unrealengine.com/latest/INT/Engine/Animation/NodeReference/SkeletalControls/index.html

in UE3 you could specify which bones can have translation (or enable it in all of them). I haven’t looked into it in UE4 but I would expect the same

Yeah I’ve looked and I don’t know what its called since it doesn’t seem to be as clear as UE3 was.

I did another test where I imported (at work different version of maya, different version of the engine but still 4.xx) worked out of the box. translation imported just fine with no extra settings. I’ll have to go home and test some more

Always a nice feeling when something just works lol, be interesting to know what knocked it out if you find out!

As far as I can tell, the only difference to get it to work is make sure to export with FBX 2014 binary not 2013 ascii. That may be it or some other small thing.

Edit: no that’s not it. As I itterate on the animation some times I export and the translation stops importing, same settings.

now I think that “bake key frames” helped…