Empty Folders Get Deleted (or remain invisible)

I typically like to determine a folder structure for a project and will create all of the empty folders I need to create that structure and later import or migrate the assets when I need/create them (ie, Characters//SUB-FOLDERS).

If I create any empty folders in Windows Explorer, UE4 will not see these folders if they don’t have any content. If you try to create a folder with the same name inside the UE4 Content Browser, you will get an error letting you know the folder all ready exists… but you can’t drag or migrate any content into it.

I have also tried to create all of your empty folder structures directly inside UE4 (a much slower workflow and more annoying than being able to do it in Windows Explorer) and then copy these same folders around to all of your different Character folders (ie, Meshes, Textures, Materials might be sub-folders for every single CharacterName folder).
This seems to work fine in that the empty folders are now visible inside of the UE4 Content Browser, however the folders don’t seem to actually get created in Windows Explorer UNTIL you add some content to the empty folders. If you Save All in UE4, and restart the program, every single empty folder that you did not add content to will now be gone.

Hi jw fitt,

I was able to reproduce this and will attach this along with my findings to a bug report to be assessed. Thank you and have a great day!

Is there an update on this, or any sort of workaround?

Hi everyone,

After having a look at this, it turns out that the asset registry will not recognize folders with no content. This is expected behavior.

Found a workaround. Make an empty actor in your base content folder> Open Explorer> navigate to content folder> use the tree view to expand to where you can see all the lowest children in the file tree> Copy the empty actor into all of the lowest children> go back into unreal, it will have picked up all your tree structure> search for the empty actors name and delete all of them. Your structure will remain intact.

How to disable this unnecessary and very VERY questionable behavior?

This bug destroys normal workflow.

Current workaround using.
Go and make in Content Folder all structure by hand and then run UE Editor.

However this is very disturbing and causes problems.
Please fix it.

Hey AG1970,

We do have an active feature request for this. See UE-8892.

However, I decided to make a new request to add this as part of the “View Options” and make it up to the user. If you want to vote on the issue, see UE-40038.

-Matt W.

Expected behaviour… I just spent a couple of hours preparing my folder structure only to see it deleted the next day. :frowning:

Hey Alphisto,

This is still something we’re considering, but haven’t implemented yet. See my latest response.

-Matt W.